summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2010-02-18 15:39:03 +0100
committerMichael Vogt <michael.vogt@ubuntu.com>2010-02-18 15:39:03 +0100
commit113942be71c90e7d6a9cff93cc05ac119db526de (patch)
tree2872bfb8c3b12dc8f9fe9e1622ddffeea528d4e6 /debian
parentb9dacd11a4707092f070d49b1cb1acff642eebf0 (diff)
parent3c5a611808e7af5aec4c2ab12ce0bce79f74928d (diff)
merge from the lp:~donkult/apt/sid branch
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog18
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules16
3 files changed, 27 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 834c86fcc..69edf559b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -15,9 +15,27 @@ apt (0.7.26) UNRELEASED; urgency=low
- allow also to skip the last patch if target is reached,
thanks Bernhard R. Link! (Closes: #545699)
* ftparchive/writer.{cc,h}:
+ - add --arch option for packages and contents commands
+ - if an arch is given accept only *_all.deb and *_arch.deb instead
+ of *.deb. Thanks Stephan Bosch for the patch! (Closes: #319710)
- add APT::FTPArchive::AlwaysStat to disable the too aggressive
caching if versions are build multiply times (not recommend)
Patch by Christoph Goehre, thanks! (Closes: #463260)
+ * apt-pkg/deb/dpkgpm.cc:
+ - stdin redirected to /dev/null takes all CPU (Closes: #569488)
+ Thanks to Aurelien Jarno for providing (again) a patch!
+ * buildlib/apti18n.h.in, po/makefile:
+ - add ngettext support with P_()
+ * aptconfiguration.cc:
+ - include all existing Translation files in the Cache (Closes: 564137)
+ * debian/control:
+ - update with no changes to debian policy 3.8.4
+ * doc/apt_preferences.5.xml:
+ - explicitly warn against careless use (Closes: #567669)
+ * debian/rules:
+ - remove creation of empty dir /usr/share/apt
+ * doc/apt-cdrom.8.xml:
+ - fix typo spotted by lintian: proc(c)eed
[ Ivan Masár ]
* Slovak translation update. Closes: #568294
diff --git a/debian/control b/debian/control
index d756871d1..de2bf6544 100644
--- a/debian/control
+++ b/debian/control
@@ -5,7 +5,7 @@ Maintainer: APT Development Team <deity@lists.debian.org>
Uploaders: Michael Vogt <mvo@debian.org>, Otavio Salvador <otavio@debian.org>,
Christian Perrier <bubulle@debian.org>, Daniel Burrows <dburrows@debian.org>,
Luca Bruno <lethalman88@gmail.com>, Julian Andres Klode <jak@debian.org>
-Standards-Version: 3.8.3
+Standards-Version: 3.8.4
Build-Depends: debhelper (>= 5.0), libdb-dev, gettext (>= 0.12), libcurl4-gnutls-dev | libcurl3-gnutls-dev (>= 7.15.5), debiandoc-sgml, xsltproc, docbook-xsl, po4a (>= 0.34-2), autotools-dev
Vcs-Bzr: http://bzr.debian.org/apt/debian-sid/
diff --git a/debian/rules b/debian/rules
index 37c96ef20..ab384b123 100755
--- a/debian/rules
+++ b/debian/rules
@@ -78,21 +78,21 @@ APT_UTILS=ftparchive sortpkgs extracttemplates
include buildlib/libversion.mak
# Determine which package we should provide in the control files
-LIBAPTPKG_PROVIDE=libapt-pkg$(LIBEXT)-$(LIBAPTPKG_MAJOR)
-LIBAPTINST_PROVIDE=libapt-inst$(LIBEXT)-$(LIBAPTINST_MAJOR)
+LIBAPTPKG_PROVIDE=libapt-pkg-$(LIBAPTPKG_MAJOR)
+LIBAPTINST_PROVIDE=libapt-inst-$(LIBAPTINST_MAJOR)
debian/shlibs.local: apt-pkg/makefile
# We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
# one for the rest of the packages. This ensures that each package gets
# the right overrides..
rm -rf $@ $@.apt $@.apt-utils
- echo "libapt-pkg$(LIBEXT) $(LIBAPTPKG_MAJOR)" > $@.apt
+ echo "libapt-pkg $(LIBAPTPKG_MAJOR)" > $@.apt
- echo "libapt-pkg$(LIBEXT) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
- echo "libapt-inst$(LIBEXT) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
+ echo "libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
+ echo "libapt-inst $(LIBAPTINST_MAJOR)" >> $@.apt-utils
- echo "libapt-pkg$(LIBEXT) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
- echo "libapt-inst$(LIBEXT) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
+ echo "libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
+ echo "libapt-inst $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
build: build/build-stamp
build-doc: build/build-doc-stamp
@@ -190,7 +190,7 @@ apt: build build-doc debian/shlibs.local
dh_testdir -p$@
dh_testroot -p$@
dh_clean -p$@ -k
- dh_installdirs -p$@ /usr/share/bug/$@ /usr/share/$@
+ dh_installdirs -p$@
#
# apt install
#