summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2009-12-10 20:48:36 +0100
committerMichael Vogt <michael.vogt@ubuntu.com>2009-12-10 20:48:36 +0100
commit3e2f480d7ad43f565bf2253fc598c2b80a22560f (patch)
tree9328c276084c60db8bcea258b35c9d69e9da4a3b /debian
parentfb3dc57975989a6514577569af9171732b7c5403 (diff)
parent944b2fffc4a54fbf9329faa579592cc758915a99 (diff)
merged -r1887..1901 from lp:~donkult/apt/sid
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog18
-rw-r--r--debian/control6
-rwxr-xr-xdebian/rules17
3 files changed, 27 insertions, 14 deletions
diff --git a/debian/changelog b/debian/changelog
index 24b166fd6..269d3c4db 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -62,6 +62,24 @@ apt (0.7.25) UNRELEASED; urgency=low
- source should displays his final pkg pick (Closes: #249383, #550952)
- source doesn't need the complete version for match (Closes: #245250)
- source ignores versions/releases if not available (Closes: #377424)
+ - only warn if (free) space overflows (Closes: #522238)
+ * methods/connect.cc:
+ - display also strerror of "wicked" getaddrinfo errors
+ * buildlib/configure.mak, buildlib/config.{sub,guess}:
+ - remove (outdated) config.{sub,guess} and use the ones provided
+ by the new added build-dependency autotools-dev instead
+
+ [ Chris Leick ]
+ * doc/ various manpages:
+ - correct various errors, typos and oddities (Closes: #552535)
+ * doc/apt-secure.8.xml:
+ - replace literal with emphasis tags in Archive configuration
+
+ [ Eugene V. Lyubimkin ]
+ * apt-pkg/contib/strutl.h
+ - Avoid extra inner copy in APT_MKSTRCMP and APT_MKSTRCMP2.
+ * build infrastructure:
+ - Bumped libapt version, excluded eglibc from SONAME. (Closes: #448249)
[ Julian Andres Klode ]
* doc/apt.conf.5.xml:
diff --git a/debian/control b/debian/control
index a9c82f9e8..5db294f2e 100644
--- a/debian/control
+++ b/debian/control
@@ -6,17 +6,15 @@ Uploaders: Michael Vogt <mvo@debian.org>, Otavio Salvador <otavio@debian.org>,
Christian Perrier <bubulle@debian.org>, Daniel Burrows <dburrows@debian.org>,
Luca Bruno <lethalman88@gmail.com>, Julian Andres Klode <jak@debian.org>
Standards-Version: 3.8.2.0
-Build-Depends: debhelper (>= 5.0), libdb-dev, gettext (>= 0.12), libcurl4-gnutls-dev | libcurl3-gnutls-dev (>= 7.15.5), debiandoc-sgml, docbook-utils (>= 0.6.12), xsltproc, docbook-xsl, xmlto, po4a (>= 0.34-2)
+Build-Depends: debhelper (>= 5.0), libdb-dev, gettext (>= 0.12), libcurl4-gnutls-dev | libcurl3-gnutls-dev (>= 7.15.5), debiandoc-sgml, docbook-utils (>= 0.6.12), xsltproc, docbook-xsl, xmlto, po4a (>= 0.34-2), autotools-dev
Vcs-Bzr: http://bzr.debian.org/apt/debian-sid/
Package: apt
Architecture: any
Depends: ${shlibs:Depends}, debian-archive-keyring
-Priority: important
Replaces: libapt-pkg-doc (<< 0.3.7), libapt-pkg-dev (<< 0.3.7)
Provides: ${libapt-pkg:provides}
Suggests: aptitude | synaptic | wajig, dpkg-dev, apt-doc, bzip2, lzma, python-apt
-Section: admin
Description: Advanced front-end for dpkg
This is Debian's next generation front-end for the dpkg package manager.
It provides the apt-get utility and APT dselect method that provides a
@@ -55,10 +53,8 @@ Description: Documentation for APT development
Package: apt-utils
Architecture: any
Depends: ${shlibs:Depends}
-Priority: important
Provides: ${libapt-inst:provides}
Replaces: apt (<< 0.5.9)
-Section: admin
Description: APT utility programs
This package contains some APT utility programs such as apt-ftparchive,
apt-sortpkgs and apt-extracttemplates.
diff --git a/debian/rules b/debian/rules
index d19531dfc..f69c0cffb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -75,25 +75,24 @@ APT_UTILS=ftparchive sortpkgs extracttemplates
#export DH_VERBOSE=1
# Find the libapt-pkg major version for use in other control files
-export LIBAPTPKG_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
-export LIBAPTINST_MAJOR:=$(shell egrep '^MAJOR=' apt-inst/makefile |cut -d '=' -f 2)
+include buildlib/libversion.mak
# Determine which package we should provide in the control files
-LIBAPTPKG_PROVIDE=libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTPKG_MAJOR)
-LIBAPTINST_PROVIDE=libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTINST_MAJOR)
+LIBAPTPKG_PROVIDE=libapt-pkg-$(LIBAPTPKG_MAJOR)
+LIBAPTINST_PROVIDE=libapt-inst-$(LIBAPTINST_MAJOR)
debian/shlibs.local: apt-pkg/makefile
# We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
# one for the rest of the packages. This ensures that each package gets
# the right overrides..
rm -rf $@ $@.apt $@.apt-utils
- echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
+ echo "libapt-pkg $(LIBAPTPKG_MAJOR)" > $@.apt
- echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
- echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
+ echo "libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
+ echo "libapt-inst $(LIBAPTINST_MAJOR)" >> $@.apt-utils
- echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
- echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
+ echo "libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
+ echo "libapt-inst $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
build: build/build-stamp
build-doc: build/build-doc-stamp