summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2006-03-28 20:36:42 +0200
committerMichael Vogt <michael.vogt@ubuntu.com>2006-03-28 20:36:42 +0200
commit980380b06f67db21af59fb5014d9bc9304bace9c (patch)
treef962591c9355a3e870902950d1c741b3f1c0d28d /debian
parent4f00fb2f265f5230c7d138b52854c0886092c0ab (diff)
parent4d745d64da784908e26a2a3a4ec00e8394b9e3c6 (diff)
* merged with mainline
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog36
-rwxr-xr-xdebian/rules3
2 files changed, 36 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 89d418572..98d5b0f6b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,40 @@
-apt (0.6.43.2ubuntu2) dapper; urgency=low
+apt (0.6.43.3ubuntu1) dapper; urgency=low
* apt-pkg/acquire.cc: don't show ETA if it is 0 or absurdely large
- -- Michael Vogt <michael.vogt@ubuntu.com> Tue, 28 Mar 2006 19:16:23 +0200
+ -- Michael Vogt <michael.vogt@ubuntu.com> Tue, 28 Mar 2006 20:34:46 +0200
+
+apt (0.6.43.3) unstable; urgency=low
+
+ * Merge bubulle@debian.org--2005/apt--main--0 up to patch-186:
+ * ca.po: Completed to 512t. Closes: #351592
+ * eu.po: Completed to 512t. Closes: #350483
+ * ja.po: Completed to 512t. Closes: #349806
+ * pl.po: Completed to 512t. Closes: #349514
+ * sk.po: Completed to 512t. Closes: #349474
+ * gl.po: Completed to 512 strings Closes: #349407
+ * vi.po: Completed to 512 strings
+ * sv.po: Completed to 512 strings Closes: #349210
+ * ru.po: Completed to 512 strings Closes: #349154
+ * da.po: Completed to 512 strings Closes: #349084
+ * fr.po: Completed to 512 strings
+ * LINGUAS: Add Welsh
+ * *.po: Updated from sources (512 strings)
+ * vi.po: Completed to 511 strings Closes: #348968
+ * apt-pkg/deb/deblistparser.cc:
+ - don't explode on a DepCompareOp in a Provides line, but warn about
+ it and ignore it otherwise (thanks to James Troup for reporting it)
+ * cmdline/apt-get.cc:
+ - don't lock the lists directory in DoInstall, breaks --print-uri
+ (thanks to James Troup for reporting it)
+ * debian/apt.dirs: create /etc/apt/sources.list.d
+ * make apt-cache madison work without deb-src entries (#352583)
+ * cmdline/apt-get.cc: only run the list-cleaner if a update was
+ successfull
+ * apt-get update errors are only warnings nowdays
+ * be more careful with the signature file on network failures
+
+ -- Michael Vogt <mvo@debian.org> Wed, 22 Feb 2006 10:13:04 +0100
apt (0.6.43.2ubuntu1) dapper; urgency=low
diff --git a/debian/rules b/debian/rules
index 34c947c69..92931b6f8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -36,6 +36,7 @@ endif
# Default rule
build:
+PKG=apt
DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
@@ -340,6 +341,6 @@ cvs-mkul:
arch-build:
rm -rf debian/arch-build
mkdir -p debian/arch-build/apt-$(APT_DEBVER)
- baz inventory -s | xargs cp -a --parents --target=debian/arch-build/apt-$(APT_DEBVER)
+ tar -c --exclude=arch-build -f - `bzr inventory` | (cd debian/arch-build/$(PKG)-$(DEBVER);tar xf -)
$(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
(cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG); dpkg-genchanges -S > ../apt_$(APT_DEBVER)_source.changes)