summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2011-08-17 18:14:27 +0200
committerMichael Vogt <michael.vogt@ubuntu.com>2011-08-17 18:14:27 +0200
commit178dd062eeaa1d7e56770455e005dc27aa71f026 (patch)
tree0dd7241e4fa9a06090d5cd8da4c7de87065ba08b /debian
parentec78b277382e27509a6dec91af4a7a524a422e0f (diff)
parentfe268128119bc73403003a29b66c927b9c36690d (diff)
merged lp:~donkult/apt/sid
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.symbols7
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/rules5
3 files changed, 18 insertions, 2 deletions
diff --git a/debian/apt.symbols b/debian/apt.symbols
index 932fb1411..7eaf61e50 100644
--- a/debian/apt.symbols
+++ b/debian/apt.symbols
@@ -563,7 +563,6 @@ libapt-pkg.so.4.10 libapt-pkg4.10
(c++)"pkgCacheGenerator::ListParser::NewProvides(pkgCache::VerIterator&, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)@Base" 0.8.0
(c++)"pkgCacheGenerator::ListParser::CollectFileProvides(pkgCache&, pkgCache::VerIterator&)@Base" 0.8.0
(c++)"pkgCacheGenerator::ListParser::~ListParser()@Base" 0.8.0
- (c++)"pkgCacheGenerator::NewDepends(pkgCache::PkgIterator&, pkgCache::VerIterator&, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, unsigned int const&, unsigned int const&, unsigned int*)@Base" 0.8.0
(c++)"pkgCacheGenerator::NewFileVer(pkgCache::VerIterator&, pkgCacheGenerator::ListParser&)@Base" 0.8.0
(c++)"pkgCacheGenerator::NewPackage(pkgCache::PkgIterator&, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)@Base" 0.8.0
(c++)"pkgCacheGenerator::NewVersion(pkgCache::VerIterator&, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, unsigned long)@Base" 0.8.0
@@ -1327,3 +1326,9 @@ libapt-pkg.so.4.10 libapt-pkg4.10
(c++)"pkgDepCache::IsModeChangeOk(pkgDepCache::ModeList, pkgCache::PkgIterator const&, unsigned long, bool)@Base" 0.8.13.2 1
(c++)"pkgPackageManager::SmartUnPack(pkgCache::PkgIterator, bool)@Base" 0.8.15~exp1 1
(c++)"pkgCache::DepIterator::IsNegative() const@Base" 0.8.15~exp1 1
+ (c++)"Configuration::CndSet(char const*, int)@Base" 0.8.15.3 1
+ (c++)"pkgProblemResolver::InstOrNewPolicyBroken(pkgCache::PkgIterator)@Base" 0.8.15.3 1
+ (c++)"DeEscapeString(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)@Base" 0.8.15.4 1
+ (c++)"GetModificationTime(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)@Base" 0.8.15.6 1
+ (c++)"pkgSourceList::GetLastModifiedTime()@Base" 0.8.15.6 1
+ (c++)"pkgCacheGenerator::NewDepends(pkgCache::PkgIterator&, pkgCache::VerIterator&, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, unsigned int const&, unsigned int const&, unsigned int*&)@Base" 0.8.15.6 1
diff --git a/debian/changelog b/debian/changelog
index 07276ef61..56d4c7e0e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,8 +5,14 @@ apt (0.8.15.7) UNRELEASED; urgency=low
- ignore "self"-conflicts for all architectures of a package
instead of just for the architecture of the package locked at
in the ordering of installations too (Closes: #802901)
+ * test/*
+ - reorganize the various testcases and helper we have and
+ integrate them better into the buildsystem
+ - run the test/libapt testcases at package build-time
+ * debian/apt.symbols:
+ - add the newly added symbols since 0.8.15.3
- -- David Kalnischkies <kalnischkies@gmail.com> Wed, 17 Aug 2011 11:08:02 +0200
+ -- David Kalnischkies <kalnischkies@gmail.com> Wed, 17 Aug 2011 15:09:16 +0200
apt (0.8.15.6) unstable; urgency=low
diff --git a/debian/rules b/debian/rules
index 640900678..d6c2dfa22 100755
--- a/debian/rules
+++ b/debian/rules
@@ -97,6 +97,11 @@ build/configure-stamp: configure
build/build-stamp: build/configure-stamp
# Add here commands to compile the package.
$(MAKE) binary
+ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
+ $(MAKE) test
+else
+ @echo "Tests DISABLED"
+endif
touch $@
build/build-doc-stamp: build/configure-stamp