summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorbubulle@debian.org <>2007-07-15 08:17:44 +0200
committerbubulle@debian.org <>2007-07-15 08:17:44 +0200
commit5ffd03998b01c174298ddb3f2f914f59bdee7481 (patch)
tree053148d6cef4f862101f30de584cae0bb5048757 /debian
parentd59821362ed1032920a72d3795176cccadaea6b0 (diff)
parent82d0afc286514bbe8904c3436bb6580aeaa6ad66 (diff)
Sync with Michael
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog25
-rwxr-xr-xdebian/rules2
2 files changed, 24 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index cb86ce580..f618b84df 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,29 @@
apt (0.7.4) UNRELEASED; urgency=low
- * Fix a typo on 0.7.3 changelog entry about g++ (7.3 to 4.3)
+ [Michael Vogt]
+ * cmdline/apt-get.cc:
+ - fix in the task-install code regexp (thanks to Adam Conrad and
+ Colin Watson)
- -- Otavio Salvador <otavio@ossystems.com.br> Mon, 02 Jul 2007 13:27:54 -0300
+ [Otavio Salvador]
+ * Fix a typo on 0.7.3 changelog entry about g++ (7.3 to 4.3)
+ * Fix compilation warnings:
+ - apt-pkg/contrib/configuration.cc: wrong argument type;
+ - apt-pkg/deb/dpkgpm.cc: wrong signess;
+ - apt-pkg-acquire-item.cc: wrong signess and orderned initializers;
+ - methods/https.cc:
+ - type conversion;
+ - unused variable;
+ - changed SetupProxy() method to void;
+ * Simplified HttpMethod::Fetch on http.cc removing Tail variable;
+ * Fix pipeline handling on http.cc (closes: #413324)
+ * Fix building to properly support binNMUs. Thanks to Daniel Schepler
+ <schepler@math.unipd.it> by the patch (closes: #359634)
+ * Fix example for Install-{Recommends,Suggests} options on
+ configure-index example file. Thanks to Peter Eisentraut
+ <peter_e@gmx.net> by the patch (closes: #432223)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Wed, 11 Jul 2007 23:20:15 +0100
apt (0.7.3) unstable; urgency=low
diff --git a/debian/rules b/debian/rules
index 3ebecfba4..473821f16 100755
--- a/debian/rules
+++ b/debian/rules
@@ -38,7 +38,7 @@ build:
PKG=apt
DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
-APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' -e 's/\+.*$$//')
+APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')