summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDavid Kalnischkies <kalnischkies@gmail.com>2011-05-17 17:26:59 +0200
committerDavid Kalnischkies <kalnischkies@gmail.com>2011-05-17 17:26:59 +0200
commit2b82aa5553eef0cd16b5803047a6b60450bee92f (patch)
tree1c82ccc9c9ab5d5f0ec892af1193f5d69f8e61ec /debian
parent470a5c38519989313514ebaec6920aafee53d798 (diff)
parent27c69dd0b36e3da7b6061e597d755f5a60a0d31b (diff)
* Implement EDSP in libapt-pkg so that all front-ends which
use the internal resolver can now be used also with external ones as the usage is hidden in between the old API * provide two edsp solvers in apt-utils: - 'dump' to quickly output a complete scenario and - 'apt' to use the internal as an external resolver
Diffstat (limited to 'debian')
-rw-r--r--debian/apt-utils.dirs2
-rw-r--r--debian/apt-utils.links1
-rw-r--r--debian/apt.dirs1
-rw-r--r--debian/changelog12
-rwxr-xr-xdebian/rules6
5 files changed, 19 insertions, 3 deletions
diff --git a/debian/apt-utils.dirs b/debian/apt-utils.dirs
index 14f5b95d7..681e55192 100644
--- a/debian/apt-utils.dirs
+++ b/debian/apt-utils.dirs
@@ -1,2 +1,2 @@
-usr/lib
+usr/lib/apt/solvers
usr/bin
diff --git a/debian/apt-utils.links b/debian/apt-utils.links
new file mode 100644
index 000000000..5bf138c4a
--- /dev/null
+++ b/debian/apt-utils.links
@@ -0,0 +1 @@
+usr/bin/apt-internal-solver usr/lib/apt/solvers/apt
diff --git a/debian/apt.dirs b/debian/apt.dirs
index 2770d79bb..f9c0b6c3e 100644
--- a/debian/apt.dirs
+++ b/debian/apt.dirs
@@ -1,5 +1,6 @@
usr/bin
usr/lib/apt/methods
+usr/lib/apt/solvers
usr/lib/dpkg/methods/apt
etc/apt
etc/apt/apt.conf.d
diff --git a/debian/changelog b/debian/changelog
index b64594c2c..16827ff8d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+apt (0.8.15) UNRELEASED; urgency=low
+
+ [ David Kalnischkies ]
+ * Implement EDSP in libapt-pkg so that all front-ends which
+ use the internal resolver can now be used also with external
+ ones as the usage is hidden in between the old API
+ * provide two edsp solvers in apt-utils:
+ - 'dump' to quickly output a complete scenario and
+ - 'apt' to use the internal as an external resolver
+
+ -- David Kalnischkies <kalnischkies@gmail.com> Tue, 17 May 2011 17:19:48 +0200
+
apt (0.8.14.2) UNRELEASED; urgency=low
[ Julian Andres Klode ]
diff --git a/debian/rules b/debian/rules
index 0544b2b8e..6c58d82bb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -62,7 +62,7 @@ configure.in:
endif
# APT Programs in apt-utils
-APT_UTILS=ftparchive sortpkgs extracttemplates
+APT_UTILS=ftparchive sortpkgs extracttemplates internal-solver
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
@@ -185,7 +185,7 @@ apt: build build-doc
dh_install -p$@ --sourcedir=$(BLD)
# Remove the bits that are in apt-utils
- rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS))
+ rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver)
# https has its own package
rm debian/$@/usr/lib/apt/methods/https
@@ -239,8 +239,10 @@ apt-utils: build
dh_installdirs -p$@
cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
+ cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
dh_install -p$@ --sourcedir=$(BLD)
+ dh_link -p$@
dh_installdocs -p$@
dh_installexamples -p$@