summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <egon@bottom>2006-12-19 14:50:16 +0100
committerMichael Vogt <egon@bottom>2006-12-19 14:50:16 +0100
commitdf01b0d0d741eae61657b28a5111f40f05c215fe (patch)
treef5ec7c4b59ecf01e9e75d37bc9f9d6c794c83167 /debian
parentc04a8d16e28bc82a76a31dba23244390a76fbcbb (diff)
parent714ee06cb1f8892f283bcdcfbb7ebbba8d642193 (diff)
* merged apt--curl-https branch
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rw-r--r--debian/control11
-rwxr-xr-xdebian/rules28
3 files changed, 39 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 52bdced8f..1ea2a294a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -13,13 +13,14 @@ apt (0.7.0) experimental; urgency=low
* support for unattended-upgrades (via unattended-upgrades
package)
-
-- Michael Vogt <mvo@debian.org> Thu, 14 Dec 2006 11:31:41 +0100
apt (0.6.46.5) UNRELEASED; urgency=low
* apt-pkg/algorithm.cc:
- use clog for all debugging
+ - only increase the score of installed applications if they
+ are not obsolete
-- Michael Vogt <mvo@debian.org> Thu, 14 Dec 2006 11:31:41 +0100
diff --git a/debian/control b/debian/control
index f331a84c1..a8ed3551f 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: important
Maintainer: APT Development Team <deity@lists.debian.org>
Uploaders: Jason Gunthorpe <jgg@debian.org>, Adam Heath <doogie@debian.org>, Matt Zimmerman <mdz@debian.org>, Michael Vogt <mvo@debian.org>
Standards-Version: 3.6.2.2
-Build-Depends: debhelper (>= 5.0), libdb4.4-dev, gettext (>= 0.12)
+Build-Depends: debhelper (>= 5.0), libdb4.4-dev, gettext (>= 0.12), libcurl3-gnutls-dev
Build-Depends-Indep: debiandoc-sgml, docbook-utils (>= 0.6.12-1)
Package: apt
@@ -64,3 +64,12 @@ Description: APT utility programs
apt-extracttemplates is used by debconf to prompt for configuration
questions before installation. apt-ftparchive is used to create Package
and other index files. apt-sortpkgs is a Package/Source file normalizer.
+
+Package: apt-transport-https
+Architecture: any
+Depends: ${shlibs:Depends}
+Priority: optional
+Section: admin
+Description: APT https transport
+ This package contains a APT https transport. It makes it possible to
+ use 'deb https://foo distro main' lines in the sources.list.
diff --git a/debian/rules b/debian/rules
index 68302daff..3ebecfba4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -185,7 +185,7 @@ apt-doc: build-doc
# Build architecture-dependent files here.
-binary-arch: apt libapt-pkg-dev apt-utils
+binary-arch: apt-transport-https apt libapt-pkg-dev apt-utils
apt: build debian/shlibs.local
dh_testdir -p$@
dh_testroot -p$@
@@ -291,6 +291,32 @@ apt-utils: build debian/shlibs.local
dh_md5sums -p$@
dh_builddeb -p$@
+apt-transport-https: build debian/shlibs.local
+ dh_testdir -p$@
+ dh_testroot -p$@
+ dh_clean -p$@ -k
+ dh_installdirs -p$@
+
+ # install the method
+ mkdir -p debian/$@/usr/lib/apt/methods
+ mv $(BLD)/bin/methods/https debian/$@/usr/lib/apt/methods
+
+ dh_installdocs -p$@
+ dh_installexamples -p$@
+
+ # Install the man pages..
+ dh_installman -p$@
+
+ dh_installchangelogs -p$@
+ dh_strip -p$@
+ dh_compress -p$@
+ dh_fixperms -p$@
+ dh_installdeb -p$@
+ dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib
+ dh_gencontrol -p$@
+ dh_md5sums -p$@
+ dh_builddeb -p$@
+
source diff:
@echo >&2 'source and diff are obsolete - use dpkg-source -b'; false