summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDavid Kalnischkies <kalnischkies@gmail.com>2012-03-22 19:29:53 +0100
committerDavid Kalnischkies <kalnischkies@gmail.com>2012-03-22 19:29:53 +0100
commit3a496cd2c06bf00d8386ff9c56e2fd26eb61ec5a (patch)
treed8abd4d7a5a38ce4c2a47002eae453f391b27c0f /debian
parent51b2a0fc603c8e4fe667bf7a278bd1ce151e38a3 (diff)
* debian/rules:
- do not sed in configure.in to set the version-number * prepare-release: - add as a small script to lazy check and prepare releases
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules14
2 files changed, 5 insertions, 15 deletions
diff --git a/debian/changelog b/debian/changelog
index 72ecc2f27..6eee11b41 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -51,8 +51,12 @@ apt (0.8.16~exp14) UNRELEASED; urgency=low
- bump Standards-Version to 3.9.3 (no changes needed)
* doc/apt-get.8.xml:
- typofix: respect → respecting, thanks Mike Erickson! (Closes: #664833)
+ * debian/rules:
+ - do not sed in configure.in to set the version-number
+ * prepare-release:
+ - add as a small script to lazy check and prepare releases
- -- David Kalnischkies <kalnischkies@gmail.com> Thu, 22 Mar 2012 12:53:34 +0100
+ -- David Kalnischkies <kalnischkies@gmail.com> Thu, 22 Mar 2012 19:23:57 +0100
apt (0.8.16~exp13) experimental; urgency=low
diff --git a/debian/rules b/debian/rules
index b819460c1..4b9510663 100755
--- a/debian/rules
+++ b/debian/rules
@@ -34,9 +34,6 @@ build:
PKG=apt
DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
-APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
-APT_CONFVER=$(shell sed -n -e 's/^PACKAGE_VERSION="\(.*\)"/\1/p' configure.in)
-APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
# Determine the build directory to use
BASE=.
@@ -53,17 +50,6 @@ ifeq ($(words $(BLD)),0)
override BLD := ./build
endif
-# Rebuild configure.in to have the correct version from the change log
-ifneq ($(APT_DEBVER),$(APT_CONFVER))
-ifneq ($(APT_DEBVER),)
-.PHONY: configure.in
-configure.in:
- sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
-endif
-else
-configure.in:
-endif
-
# APT Programs in apt-utils
APT_UTILS=ftparchive sortpkgs extracttemplates internal-solver