summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@debian.org>2005-03-30 23:21:11 +0000
committerOtavio Salvador <otavio@debian.org>2005-03-30 23:21:11 +0000
commit42ac13b328d84f385fbe09740a6bbf65f9d9b073 (patch)
tree72d609041129e679658d0877d1e957c3b9cb5852 /debian
parente55e9b3b30427ff8febe18731bd7cfc53f69e2fa (diff)
parentd73e594e888fbc099bba84726df72eedcee5272c (diff)
Sync with apt@packages.debian.org/apt--main--0--patch-74
Patches applied: * apt@packages.debian.org/apt--main--0--patch-72 Open 0.6.36 * apt@packages.debian.org/apt--main--0--patch-73 Merge apt--mvo--0 * apt@packages.debian.org/apt--main--0--patch-74 Update changelog * michael.vogt@ubuntu.com--2005/apt--mvo--0--patch-9 * be more carefull when building the archive path (thanks to matt!) * michael.vogt@ubuntu.com--2005/apt--mvo--0--patch-10 * ignore time conflicts on apt-key update (this is used at install time when the clock may be totally broken) * michael.vogt@ubuntu.com--2005/apt--mvo--0--patch-11 * run check_size_constraints independent of AUTOCLEAN (thanks Matt) * michael.vogt@ubuntu.com--2005/apt--mvo--0--patch-12 * check cache size after AUTOCLEAN was run (but independent) * michael.vogt@ubuntu.com--2005/apt--mvo--0--patch-13 * MinAge implemented, cron script variables documented, bugfix in check_stamp() function
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily66
-rw-r--r--debian/changelog12
2 files changed, 73 insertions, 5 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 982a35d74..7ee7e46db 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -2,6 +2,33 @@
#
#set -e
+#
+# This file understands the following apt configuration variables:
+#
+# "APT::Periodic::Update-Package-Lists=1"
+# - Do "apt-get update" automatically every n-days (0=disable)
+#
+# "APT::Periodic::Download-Upgradeable-Packages=0",
+# - Do "apt-get upgrade --download-only" every n-days (0=disable)
+#
+# "APT::Periodic::AutocleanInterval"
+# - Do "apt-get autoclean" every n-days (0=disable)
+#
+# "APT::Archives::MaxAge",
+# - Set maximum allowed age of a cache package file. If a cache
+# package file is older it is deleted (0=disable)
+#
+# "APT::Archives::MaxSize",
+# - Set maximum size of the cache in MB (0=disable). If the cache
+# is bigger, cached package files are deleted until the size
+# requirement is met (the biggest packages will be deleted
+# first).
+#
+# "APT::Archives::MinAge"
+# - Set minimum age of a package file. If a file is younger it
+# will not be deleted (0=disable). Usefull to prevent races
+# and to keep backups of the packages for emergency.
+#
check_stamp()
{
@@ -21,6 +48,11 @@ check_stamp()
now=$(date --date=$(date --iso-8601) +%s)
delta=$(($now-$stamp))
+ # intervall is in days,
+ interval=$(($interval*60*60*24))
+ #echo "stampfile: $1"
+ #echo "interval=$interval, now=$now, stamp=$stamp, delta=$delta"
+
if [ $delta -ge $interval ]; then
return 0
fi
@@ -42,11 +74,14 @@ check_size_constraints()
{
# min-age in days
MaxAge=0
+ MinAge=1
MaxSize=0
CacheDir="var/cache/apt"
CacheArchive="archives/"
eval $(apt-config shell MaxAge APT::Archives::MaxAge)
+ eval $(apt-config shell MinAge APT::Archives::MinAge)
eval $(apt-config shell MaxSize APT::Archives::MaxSize)
+ eval $(apt-config shell Dir Dir)
eval $(apt-config shell CacheDir Dir::Cache)
eval $(apt-config shell CacheArchive Dir::Cache::archives)
@@ -55,15 +90,25 @@ check_size_constraints()
echo "empty Dir::Cache or Dir::Cache::archives, exiting"
exit
fi
- Cache="/"$CacheDir$CacheArchive
+
+ Cache="${Dir%/}/${CacheDir%/}/${CacheArchive%/}/"
# check age
- if [ ! $MaxAge -eq 0 ]; then
+ if [ ! $MaxAge -eq 0 ] && [ ! $MinAge -eq 0 ]; then
+ find $Cache -name "*.deb" -mtime +$MaxAge -and -not -mtime -$MinAge -print0 | xargs -r -0 rm -f
+ elif [ ! $MaxAge -eq 0 ]; then
find $Cache -name "*.deb" -mtime +$MaxAge -print0 | xargs -r -0 rm -f
fi
# check size
if [ ! $MaxSize -eq 0 ]; then
+ # maxSize is in MB
+ MaxSize=$(($MaxSize*1024))
+
+ #get current time
+ now=$(date --date=$(date --iso-8601) +%s)
+ MinAge=$(($MinAge*24*60*60))
+
# reverse-sort by mtime
for file in $(ls -rt $Cache/*.deb); do
du=$(du -s $Cache)
@@ -72,13 +117,24 @@ check_size_constraints()
if [ $size -lt $MaxSize ]; then
break
fi
+
+ # check for MinAge of the file
+ if [ ! $MinAge -eq 0 ]; then
+ mtime=$(date --date=$(date -r $file --iso-8601) +%s)
+ delta=$(($now-$mtime))
+ #echo "$file ($delta), $MinAge"
+ if [ $delta -le $MinAge ]; then
+ #echo "Skiping $file (delta=$delta)"
+ continue
+ fi
+ fi
+
# delete oldest file
rm -f $file
done
fi
}
-check_size_constraints
UpdateInterval=0
DownloadUpgradeableInterval=0
@@ -117,6 +173,8 @@ fi
AUTOCLEAN_STAMP=/var/lib/apt/periodic/autoclean-stamp
if check_stamp $AUTOCLEAN_STAMP $AutocleanInterval; then
apt-get -qq autoclean
- check_size_contrains
update_stamp $AUTOCLEAN_STAMP
fi
+
+# check cache size
+check_size_constraints
diff --git a/debian/changelog b/debian/changelog
index 3059f245c..974ba5ec7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,11 +6,21 @@ apt (0.6.35os1) unstable; urgency=low
-- Otavio Salvador <otavio@debian.org> Wed, 23 Mar 2005 17:19:28 -0300
+apt (0.6.36) hoary; urgency=low
+
+ *
+
+ -- Matt Zimmerman <mdz@ubuntu.com> Sat, 26 Mar 2005 08:27:23 -0800
+
apt (0.6.35) hoary; urgency=low
- * Merge apt--mvo--0:
+ * Merge apt--mvo--0 (incorporates 0.6.34ubuntu1):
- Implement MaxSize and MaxAge in apt.cron.daily, to prevent the cache
from growing too large (Ubuntu #6761)
+ * some comments about the pkgAcqMetaSig::Custom600Headers() added
+ * use gpg --with-colons
+ * commented the ftp no_proxy unseting in methods/ftp.cc
+ * added support for "Acquire::gpgv::options" in methods/gpgv.cc
-- Matt Zimmerman <mdz@ubuntu.com> Mon, 7 Mar 2005 20:08:33 -0800