summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2009-03-30 14:00:00 +0200
committerMichael Vogt <michael.vogt@ubuntu.com>2009-03-30 14:00:00 +0200
commit5f71505b4f885ecd045c6fe40598e22ef9f328b7 (patch)
tree2988b56d4907cb9cedd28c8ebe5cb82177742112 /debian
parent20f6e22e3af58a073579af43691d316927e4a69d (diff)
merge fix for cache locking from debian (closes: #459344)
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily37
-rw-r--r--debian/changelog1
2 files changed, 19 insertions, 19 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index bb72780a5..d980efd7d 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -175,10 +175,16 @@ DownloadUpgradeableInterval=0
eval $(apt-config shell UpdateInterval APT::Periodic::Update-Package-Lists DownloadUpgradeableInterval APT::Periodic::Download-Upgradeable-Packages)
AutocleanInterval=$DownloadUpgradeableInterval
eval $(apt-config shell AutocleanInterval APT::Periodic::AutocleanInterval)
-
UnattendedUpgradeInterval=0
eval $(apt-config shell UnattendedUpgradeInterval APT::Periodic::Unattended-Upgrade)
+# check if we actually have to do anything
+if [ $UpdateInterval -eq 0 ] &&
+ [ $DownloadUpgradeableInterval -eq 0 ] &&
+ [ $UnattendedUpgradeInterval -eq 0 ] &&
+ [ $AutocleanInterval -eq 0 ]; then
+ exit 0
+fi
# laptop check, on_ac_power returns:
# 0 (true) System is on mains power
@@ -192,19 +198,20 @@ if which on_ac_power >/dev/null; then
fi
fi
-# check if we can lock the cache and if the cache is clean
-# There's a reasonable chance that someone is already running an apt
-# frontend that has locked the cache, so exit quietly if it is locked.
-if ! apt-get check -q -q 2>/dev/null; then
- exit 0
-fi
-
-# sleep random amount of time
+# sleep random amount of time to avoid hitting the
+# mirrors at the same time
random_sleep
-# check again if we can access the cache
+# check if we can access the cache
if ! apt-get check -q -q 2>/dev/null; then
- exit 1
+ # wait random amount of time before retrying
+ random_sleep
+ # check again
+ if ! apt-get check -q -q 2>/dev/null; then
+ echo "$0: could not lock the APT cache while performing daily cron job. "
+ echo "Is another package manager working?"
+ exit 1
+ fi
fi
# set the proxy based on the admin users gconf settings
@@ -218,14 +225,6 @@ if [ -n "$admin_user" ] && [ -x /usr/bin/sudo ] && [ -z "$http_proxy" ] && [ -x
fi
fi
-# sleep random amount of time
-random_sleep
-
-# check again if we can access the cache
-if ! apt-get check -q -q 2>/dev/null; then
- exit 1
-fi
-
UPDATE_STAMP=/var/lib/apt/periodic/update-stamp
if check_stamp $UPDATE_STAMP $UpdateInterval; then
# check for a new archive signing key (against the master keyring)
diff --git a/debian/changelog b/debian/changelog
index 62ce48ed9..f03be0cd5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,6 +9,7 @@ apt (0.7.20.2ubuntu5) jaunty; urgency=low
* debian/apt.cron.daily:
- do not clutter cron mail with bogus gconftool messages
(LP: #223502)
+ - merge fix for cache locking from debian (closes: #459344)
-- Michael Vogt <michael.vogt@ubuntu.com> Mon, 30 Mar 2009 13:22:28 +0200