summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2010-08-24 21:44:11 +0200
committerMichael Vogt <michael.vogt@ubuntu.com>2010-08-24 21:44:11 +0200
commit17ea77d3332ce3abbbc96a9e110a37ae055ac422 (patch)
tree611708d199721f5bca0ea4826d03da0016f3780d /debian
parent7e32e3e58d5499056b17acd0a9992704e3f55951 (diff)
parent39ee79d5b84390ae79d8cce9389c1541bcd68a25 (diff)
* merged from debian/unstable
* merge of the debian-expermental-ma branch * refresh po/pot files in doc/ and po/ * Fix spelling error in cmdline/apt-get.cc. Thanks to Osamu Aoki Closes: #594211 * Swedish (Daniel Nylander). Closes: #592366 * French (Christian Perrier) * Thai (Theppitak Karoonboonyanan). Closes: #592695 * Russian (Yuri Kozlov). Closes: #594232 * French (Christian Perrier) * apt-pkg/contrib/strutl.cc: - fix error checking for vsnprintf in its safe variant * methods/bzip2.cc: - fix error checking for read in case of failing bzip2/lzma/whatever * debian/apt.cron.daily: - create backups for our extended_states file (Closes: #593430) * apt-pkg/init.cc: - set the default values for dir::etc::trusted options correctly * ftparchive/writer.cc: - init valid-until correctly to prevent garbage entering Release file * apt-pkg/deb/debsystem.cc: - set dir::state::status based at least on dir * apt-pkg/deb/dpkgpm.cc: - use the InstVer instead of the CurrentVer for the autobit transfer * methods/http.cc: - some http servers violate HTTP1.1 by not issuing a Reason-Phrase (or at least a space after the code) especially for 200, but lets be nice and ignore it as we don't need the reason in general * apt-pkg/acquire-item.cc: - don't use ReadOnlyGzip mode for PDiffs as this mode doesn't work in combination with the AddFd methods of our hashclasses
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily9
-rw-r--r--debian/changelog54
2 files changed, 63 insertions, 0 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index f5f689127..bee0a8f01 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -320,6 +320,15 @@ debug_echo()
# ------------------------ main ----------------------------
+# Backup the 7 last versions of APT's extended_states file
+# shameless copy from dpkg cron
+if cd /var/backups ; then
+ if ! cmp -s apt.extended_states.0 /var/lib/apt/extended_states; then
+ cp -p /var/lib/apt/extended_states apt.extended_states
+ savelog -c 7 apt.extended_states >/dev/null
+ fi
+fi
+
# check apt-config exstance
if ! which apt-config >/dev/null ; then
exit 0
diff --git a/debian/changelog b/debian/changelog
index 6028fae17..cc358eaf6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,57 @@
+apt (0.8.0ubuntu1) maverick; urgency=low
+
+ * merged from debian/unstable
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Tue, 24 Aug 2010 21:39:06 +0200
+
+apt (0.8.0) unstable; urgency=low
+
+ [ Michael Vogt ]
+ * merge of the debian-expermental-ma branch
+ * refresh po/pot files in doc/ and po/
+
+ [ Christian Perrier ]
+ * Fix spelling error in cmdline/apt-get.cc. Thanks to Osamu Aoki
+ Closes: #594211
+
+ [ Programs translations ]
+ * Swedish (Daniel Nylander). Closes: #592366
+ * French (Christian Perrier)
+ * Thai (Theppitak Karoonboonyanan). Closes: #592695
+ * Russian (Yuri Kozlov). Closes: #594232
+
+ [ Manpages translations ]
+ * French (Christian Perrier)
+
+ -- Michael Vogt <mvo@debian.org> Tue, 24 Aug 2010 16:32:19 +0200
+
+apt (0.8.0~pre2) experimental; urgency=low
+
+ [ David Kalnischkies ]
+ * apt-pkg/contrib/strutl.cc:
+ - fix error checking for vsnprintf in its safe variant
+ * methods/bzip2.cc:
+ - fix error checking for read in case of failing bzip2/lzma/whatever
+ * debian/apt.cron.daily:
+ - create backups for our extended_states file (Closes: #593430)
+ * apt-pkg/init.cc:
+ - set the default values for dir::etc::trusted options correctly
+ * ftparchive/writer.cc:
+ - init valid-until correctly to prevent garbage entering Release file
+ * apt-pkg/deb/debsystem.cc:
+ - set dir::state::status based at least on dir
+ * apt-pkg/deb/dpkgpm.cc:
+ - use the InstVer instead of the CurrentVer for the autobit transfer
+ * methods/http.cc:
+ - some http servers violate HTTP1.1 by not issuing a Reason-Phrase
+ (or at least a space after the code) especially for 200, but lets
+ be nice and ignore it as we don't need the reason in general
+ * apt-pkg/acquire-item.cc:
+ - don't use ReadOnlyGzip mode for PDiffs as this mode doesn't work
+ in combination with the AddFd methods of our hashclasses
+
+ -- Michael Vogt <mvo@debian.org> Mon, 23 Aug 2010 19:09:08 +0200
+
apt (0.8.0~pre1ubuntu2) maverick; urgency=low
* apt-pkg/deb/dpkgpm.cc: