summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <egon@tas>2006-12-07 11:45:13 +0100
committerMichael Vogt <egon@tas>2006-12-07 11:45:13 +0100
commit207825063be51d68768e242f06b26ee6fccd3aaf (patch)
tree4c755597279d2574e787460c5d0f3bc34d132a64 /debian
parent7106240056767caad5a55fe9c542842065cb5829 (diff)
parent1c05ebd6da9491d316997a98db1451f7b0526603 (diff)
merged with apt--mvo
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily14
-rw-r--r--debian/apt.dirs1
-rw-r--r--debian/apt.postinst2
-rw-r--r--debian/changelog410
-rw-r--r--debian/compat2
-rw-r--r--debian/control7
-rw-r--r--debian/libapt-pkg-doc.doc-base.cache2
-rwxr-xr-xdebian/postinst5
-rwxr-xr-xdebian/rules5
9 files changed, 436 insertions, 12 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 2d93a5ba4..26dfa2530 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -95,9 +95,9 @@ check_size_constraints()
# check age
if [ ! $MaxAge -eq 0 ] && [ ! $MinAge -eq 0 ]; then
- find $Cache -name "*.deb" -mtime +$MaxAge -and -not -mtime -$MinAge -print0 | xargs -r -0 rm -f
+ find $Cache -name "*.deb" \( -mtime +$MaxAge -and -ctime +$MaxAge \) -and -not \( -mtime -$MinAge -or -ctime -$MinAge \) -print0 | xargs -r -0 rm -f
elif [ ! $MaxAge -eq 0 ]; then
- find $Cache -name "*.deb" -mtime +$MaxAge -print0 | xargs -r -0 rm -f
+ find $Cache -name "*.deb" -ctime +$MaxAge -and -mtime +$MaxAge -print0 | xargs -r -0 rm -f
fi
# check size
@@ -120,8 +120,14 @@ check_size_constraints()
# check for MinAge of the file
if [ ! $MinAge -eq 0 ]; then
- mtime=$(date --date=$(date -r $file --iso-8601) +%s)
- delta=$(($now-$mtime))
+ # check both ctime and mtime
+ mtime=$(stat -c %Y $file)
+ ctime=$(stat -c %Z $file)
+ if [ $mtime -gt $ctime ]; then
+ delta=$(($now-$mtime))
+ else
+ delta=$(($now-$ctime))
+ fi
#echo "$file ($delta), $MinAge"
if [ $delta -le $MinAge ]; then
#echo "Skiping $file (delta=$delta)"
diff --git a/debian/apt.dirs b/debian/apt.dirs
index d39bfd1f7..e1cb738fa 100644
--- a/debian/apt.dirs
+++ b/debian/apt.dirs
@@ -2,6 +2,7 @@ usr/bin
usr/lib/apt/methods
usr/lib/dpkg/methods/apt
etc/apt
+etc/apt/sources.list.d
var/cache/apt/archives/partial
var/lib/apt/lists/partial
var/lib/apt/periodic
diff --git a/debian/apt.postinst b/debian/apt.postinst
index ae1801198..88fb932df 100644
--- a/debian/apt.postinst
+++ b/debian/apt.postinst
@@ -20,6 +20,8 @@ case "$1" in
cp /usr/share/apt/debian-archive.gpg /etc/apt/trusted.gpg
fi
+ apt-key update
+
;;
abort-upgrade|abort-remove|abort-deconfigure)
diff --git a/debian/changelog b/debian/changelog
index cc3da8f84..fc17d2f56 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,413 @@
+apt (0.6.46.4) unstable; urgency=high
+
+ * ack NMU (closes: #401017)
+ * added apt-secure.8 to "See also" section
+ * apt-pkg/deb/dpkgpm.cc:
+ - added "Dpkg::StopOnError" variable that controls if apt
+ will abort on errors from dpkg
+ * apt-pkg/deb/debsrcrecords.{cc,h}:
+ - make the Buffer grow dynmaically (closes: #400874)
+ * Merged from Christian Perrier bzr branch:
+ - uk.po: New Ukrainian translation: 483t28f3u
+ - el.po: Update to 503t9f2u
+ - de.po: Updates and corrections.
+ * apt-pkg/contrib/progress.cc:
+ - OpProgress::CheckChange optimized, thanks to Paul Brook
+ (closes: #398381)
+ * apt-pkg/contrib/sha256.cc:
+ - fix building with noopt
+
+ -- Michael Vogt <mvo@debian.org> Thu, 7 Dec 2006 10:49:50 +0100
+
+apt (0.6.46.3-0.2) unstable; urgency=high
+
+ * Non-maintainer upload with permission of Michael Vogt.
+ * Fix FTBFS on most arches (regression from the fix of #400874)
+
+ -- Andreas Barth <aba@not.so.argh.org> Tue, 5 Dec 2006 15:51:22 +0000
+
+apt (0.6.46.3-0.1) unstable; urgency=high
+
+ * Non-maintainer upload with permission of Michael Vogt.
+ * Fix segfault at apt-get source. Closes: #400874
+ * Add apt-key update in postinst, so that debian-archive-keyring doesn't
+ need to depend on apt >= 0.6. Closes: #401114
+ * Don't double-queue pdiff files. Closes: #401017
+
+ -- Andreas Barth <aba@not.so.argh.org> Tue, 5 Dec 2006 10:34:56 +0000
+
+apt (0.6.46.3) unstable; urgency=low
+
+ * apt-pkg/deb/dpkgpm.cc:
+ - make progress reporting robust against multiline error
+ messages
+
+ * Merged from Christian Perrier bzr branch:
+ - ca.po: Updated to 514t
+ - be.po: Updated to 514t
+ - it.po: Updated to 514t
+ - hu.po: Updated to 514t
+ - zh_TW.po: Updated to 514t
+ - ar.po: Updated to 293t221u.
+ - ru.po: Updated to 514t. Closes: #392466
+ - nb.po: Updated to 514t. Closes: #392466
+ - pt.po: Updated to 514t. Closes: #393199
+ - fr.po: One spelling error corrected: s/accèder/accéder
+ - km.po: Updated to 514t.
+ - ko.po: Updated to 514t.
+ - bg.po: Updated to 514t.
+ - de.po: Updated to 514t.
+ - en_GB.po: Updated to 514t.
+
+ -- Michael Vogt <mvo@debian.org> Thu, 2 Nov 2006 11:37:58 +0100
+
+apt (0.6.46.2) unstable; urgency=low
+
+ * Merged from Christian Perrier bzr branch:
+ - es.po: Updated to 514t. Closes: #391661
+ - da.po: Updated to 514t. Closes: #391424
+ - cs.po: Updated. Closes: #391064
+ - es.po: Updated to 514t. Closes: #391661
+ - da.po: Updated to 514t. Closes: #391424
+
+ -- Michael Vogt <mvo@debian.org> Wed, 11 Oct 2006 09:03:15 +0200
+
+apt (0.6.46.1) unstable; urgency=low
+
+ * methods/gzip.cc:
+ - deal with empty files
+ * Applied patch from Daniel Schepler to make apt bin-NMU able.
+ (closes: bug#359634)
+ * rebuild against current g++ because of:
+ http://gcc.gnu.org/bugzilla/show_bug.cgi?id=29289
+ (closes: #390189)
+ * fix broken i18n in the dpkg progress reporting, thanks to
+ Frans Pop and Steinar Gunderson. (closes: #389261)
+ * Merged from Christian Perrier bzr branch:
+ * fi.po: Updated to 514t. Closes: #390149
+ * eu.po: Updated to 514t. Closes: #389725
+ * vi.po: Updated to 514t. Closes: #388555
+ * make the internal buffer in pkgTagFile grow dynamically
+ (closes: #388708)
+
+ -- Michael Vogt <mvo@debian.org> Mon, 2 Oct 2006 20:42:20 +0200
+
+apt (0.6.46) unstable; urgency=low
+
+ * debian/control:
+ - switched to libdb4.4 for building (closes: #381019)
+ * cmdline/apt-get.cc:
+ - show only the recommends/suggests for the candidate-version, not for all
+ versions of the package (closes: #257054)
+ - properly handle recommends/suggests or-groups when printing the list of
+ suggested/recommends packages (closes: #311619)
+ * methods/http.cc:
+ - check more careful for incorrect proxy settings (closes: #378868)
+ * methods/gzip.cc:
+ - don't hang when /var is full (closes: #341537), thanks to
+ Luis Rodrigo Gallardo Cruz for the patch
+ * doc/examples/sources.list:
+ - removed non-us.debian.org from the example (closes: #380030,#316196)
+ * Merged from Christian Perrier bzr branch:
+ * ro.po: Updated to 514t. Closes: #388402
+ * dz.po: Updated to 514t. Closes: #388184
+ * it.po: Fixed typos. Closes: #387812
+ * ku.po: New kurdish translation. Closes: #387766
+ * sk.po: Updated to 514t. Closes: #386851
+ * ja.po: Updated to 514t. Closes: #386537
+ * gl.po: Updated to 514t. Closes: #386397
+ * fr.po: Updated to 516t.
+ * fi.po: Updated to 512t. Closes: #382702
+ * share/archive-archive.gpg:
+ - removed the outdated amd64 and debian-2004 keys
+ * apt-pkg/tagfile.cc:
+ - applied patch from Jeroen van Wolffelaar to make the tags
+ caseinsensitive (closes: #384182)
+ - reverted MMap use in the tagfile because it does not work
+ across pipes (closes: #383487)
+
+ -- Michael Vogt <mvo@debian.org> Thu, 21 Sep 2006 10:25:03 +0200
+
+apt (0.6.45) unstable; urgency=low
+
+ * apt-pkg/contrib/sha256.cc:
+ - fixed the sha256 generation (closes: #378183)
+ * ftparchive/cachedb.cc:
+ - applied patch from Anthony Towns to fix Clean() function
+ (closes: #379576)
+ * doc/apt-get.8.xml:
+ - fix path to the apt user build (Closes: #375640)
+ * doc/apt-cache.8.xml:
+ - typo (Closes: #376408)
+ * apt-pkg/deb/dpkgpm.cc:
+ - make progress reporting more robust against multiline error
+ messages (first half of a fix for #374195)
+ * doc/examples/configure-index:
+ - document Debug::pkgAcquire::Auth
+ * methods/gpgv.cc:
+ - deal with gpg error "NODATA". Closes: #296103, Thanks to
+ Luis Rodrigo Gallardo Cruz for the patch
+ * apt-inst/contrib/extracttar.cc:
+ - fix for string mangling, closes: #373864
+ * apt-pkg/acquire-item.cc:
+ - check for bzip2 in /bin (closes: #377391)
+ * apt-pkg/tagfile.cc:
+ - make it work on non-mapable files again, thanks
+ to James Troup for confirming the fix (closes: #376777)
+ * Merged from Christian Perrier bzr branch:
+ * ko.po: Updated to 512t. Closes: #378901
+ * hu.po: Updated to 512t. Closes: #376330
+ * km.po: New Khmer translation: 506t6f. Closes: #375068
+ * ne.po: New Nepali translation: 512t. Closes: #373729
+ * vi.po: Updated to 512t. Closes: #368038
+ * zh_TW.po: Remove an extra %s in one string. Closes: #370551
+ * dz.po: New Dzongkha translation: 512t
+ * ro.po: Updated to 512t
+ * eu.po: Updated
+
+ -- Michael Vogt <mvo@debian.org> Thu, 27 Jul 2006 00:52:05 +0200
+
+apt (0.6.44.2) unstable; urgency=low
+
+ * apt-pkg/depcache.cc:
+ - added Debug::pkgDepCache::AutoInstall (thanks to infinity)
+ * apt-pkg/acquire-item.cc:
+ - fix missing chmod() in the new aquire code
+ (thanks to Bastian Blank, Closes: #367425)
+ * merged from
+ http://www.perrier.eu.org/debian/packages/d-i/level4/apt-main:
+ * sk.po: Completed to 512t
+ * eu.po: Completed to 512t
+ * fr.po: Completed to 512t
+ * sv.po: Completed to 512t
+ * Update all PO and the POT. Gives 506t6f for formerly
+ complete translations
+
+ -- Michael Vogt <mvo@debian.org> Wed, 14 Jun 2006 12:00:57 +0200
+
+apt (0.6.44.1-0.1) unstable; urgency=low
+
+ * Non-maintainer upload.
+ * Don't give an error when parsing empty Packages/Sources files.
+ (Closes: #366931, #367086, #370160)
+
+ -- Steinar H. Gunderson <sesse@debian.org> Fri, 9 Jun 2006 00:52:21 +0200
+
+apt (0.6.44.1) unstable; urgency=low
+
+ * merged from
+ http://www.perrier.eu.org/debian/packages/d-i/level4/apt-main:
+ - po/LINGUAS: added "bg" Closes: #360262
+ - po/gl.po: Galician translation update. Closes: #366849
+ - po/hu.po: Hungarian translation update. Closes: #365448
+ - po/cs.po: Czech translation updated. Closes: #367244
+
+ -- Michael Vogt <mvo@debian.org> Tue, 16 May 2006 21:51:16 +0200
+
+apt (0.6.44) unstable; urgency=low
+
+ * apt-pkg/acquire.cc: don't show ETA if it is 0 or absurdely large
+ * apt-pkg/deb/dpkgpm.cc:
+ - wording fixes (thanks to Matt Zimmerman)
+ - fix error in dpkg interaction (closes: #364513,
+ thanks to Martin Dickopp)
+ * apt-pkg/tagfile.{cc,h}:
+ - use MMap to read the entries (thanks to Zephaniah E. Hull for the
+ patch) Closes: #350025
+ * Merge from http://www.perrier.eu.org/debian/packages/d-i/level4/apt-main:
+ * bg.po: Added, complete to 512t. Closes: #360262
+ * doc/apt-ftparchive.1.xml:
+ - fix documentation for "SrcPackages" -> "Sources"
+ (thanks to Bart Martens for the patch, closes: #307756)
+ * debian/libapt-pkg-doc.doc-base.cache:
+ - remove broken charackter from description (closes: #361129)
+ * apt-inst/deb/dpkgdb.cc, methods/gpgv.cc:
+ - i18n fixes (closes: #349298)
+ * debian/postinst: dont fail on not available
+ /usr/share/doc/apt/examples/sources.list (closes: #361130)
+ * methods/ftp.cc:
+ - unlink empty file in partial if the download failed because
+ the file is missing on the server (closes: #316337)
+ * apt-pkg/deb/debversion.cc:
+ - treats a version string with explicit zero epoch equal
+ than the same without epoch (Policy 5.6.12, closes: #363358)
+ Thanks to Lionel Elie Mamane for the patch
+
+ -- Michael Vogt <mvo@debian.org> Mon, 8 May 2006 22:28:53 +0200
+
+apt (0.6.43.3) unstable; urgency=low
+
+ * Merge bubulle@debian.org--2005/apt--main--0 up to patch-186:
+ * ca.po: Completed to 512t. Closes: #351592
+ * eu.po: Completed to 512t. Closes: #350483
+ * ja.po: Completed to 512t. Closes: #349806
+ * pl.po: Completed to 512t. Closes: #349514
+ * sk.po: Completed to 512t. Closes: #349474
+ * gl.po: Completed to 512 strings Closes: #349407
+ * sv.po: Completed to 512 strings Closes: #349210
+ * ru.po: Completed to 512 strings Closes: #349154
+ * da.po: Completed to 512 strings Closes: #349084
+ * fr.po: Completed to 512 strings
+ * vi.po: Completed to 511 strings Closes: #348968
+ * zh_CN.po: Completed to 512t. Closes: #353936
+ * it.po: Completed to 512t. Closes: #352803
+ * pt_BR.po: Completed to 512t. Closes: #352419
+ * LINGUAS: Add Welsh
+ * *.po: Updated from sources (512 strings)
+ * apt-pkg/deb/deblistparser.cc:
+ - don't explode on a DepCompareOp in a Provides line, but warn about
+ it and ignore it otherwise (thanks to James Troup for reporting it)
+ * cmdline/apt-get.cc:
+ - don't lock the lists directory in DoInstall, breaks --print-uri
+ (thanks to James Troup for reporting it)
+ * debian/apt.dirs: create /etc/apt/sources.list.d
+ * make apt-cache madison work without deb-src entries (#352583)
+ * cmdline/apt-get.cc: only run the list-cleaner if a update was
+ successfull
+
+ -- Michael Vogt <mvo@debian.org> Wed, 22 Feb 2006 10:13:04 +0100
+
+apt (0.6.43.2) unstable; urgency=low
+
+ * Merge bubulle@debian.org--2005/apt--main--0 up to patch-166:
+ - en_GB.po, de.po: fix spaces errors in "Ign " translations Closes: #347258
+ - makefile: make update-po a pre-requisite of clean target so
+ that POT and PO files are always up-to-date
+ - sv.po: Completed to 511t. Closes: #346450
+ - sk.po: Completed to 511t. Closes: #346369
+ - fr.po: Completed to 511t
+ - *.po: Updated from sources (511 strings)
+ - el.po: Completed to 511 strings Closes: #344642
+ - da.po: Completed to 511 strings Closes: #348574
+ - es.po: Updated to 510t1f Closes: #348158
+ - gl.po: Completed to 511 strings Closes: #347729
+ - it.po: Yet another update Closes: #347435
+ * added debian-archive-keyring to the Recommends (closes: #347970)
+ * fixed message in apt-key to install debian-archive-keyring
+ * typos fixed in apt-cache.8 (closes: #348348, #347349)
+ * add patch to fix http download corruption problem (thanks to
+ Petr Vandrovec, closes: #280844, #290694)
+
+ -- Michael Vogt <mvo@debian.org> Thu, 19 Jan 2006 00:06:33 +0100
+
+apt (0.6.43.1) unstable; urgency=low
+
+ * Merge bubulle@debian.org--2005/apt--main--0 up to patch-148:
+ * fr.po: Completed to 510 strings
+ * it.po: Completed to 510t
+ * en_GB.po: Completed to 510t
+ * cs.po: Completed to 510t
+ * zh_CN.po: Completed to 510t
+ * el.po: Updated to 510t
+ * vi.po: Updated to 383t93f34u
+ * tl.po: Completed to 510 strings (Closes: #344306)
+ * sv.po: Completed to 510 strings (Closes: #344056)
+ * LINGUAS: disabled Hebrew translation. (Closes: #313283)
+ * eu.po: Completed to 510 strings (Closes: #342091)
+ * apt-get source won't download already downloaded files again
+ (closes: #79277)
+ * share/debian-archive.gpg: new 2006 ftp-archive signing key added
+ (#345891)
+ * redownload the Release file if IMS-Hit and gpg failure
+ * deal with multiple signatures on a Release file
+
+ -- Michael Vogt <mvo@debian.org> Fri, 6 Jan 2006 01:17:08 +0100
+
+apt (0.6.43) unstable; urgency=medium
+
+ * Merge bubulle@debian.org--2005/apt--main--0 up to patch-132:
+ * zh_CN.po: Completed to 510 strings(Closes: #338267)
+ * gl.po: Completed to 510 strings (Closes: #338356)
+ * added support for "/etc/apt/sources.list.d" directory
+ (closes: #66325)
+ * make pkgDirStream (a bit) more complete
+ * fix bug in pkgCache::VerIterator::end() (thanks to Daniel Burrows)
+ (closes: #339533)
+ * pkgAcqFile is more flexible now (closes: #57091)
+ * support a download rate limit for http (closes: #146877)
+ * included lots of the speedup changes from #319377
+ * add stdint.h to contrib/md5.h (closes: #340448)
+ * ABI change, library name changed (closes: #339147)
+ * Fix GNU/kFreeBSD crash on non-existing server file (closes: #317718)
+ * switch to libdb4.3 in build-depends
+
+ -- Michael Vogt <mvo@debian.org> Tue, 29 Nov 2005 00:17:07 +0100
+
+apt (0.6.42.3) unstable; urgency=low
+
+ * Merge bubulle@debian.org--2005/apt--main--0 up to patch-129:
+ - patch-118: Russian translation update by Yuri Kozlov (closes: #335164)
+ - patch-119: add update-po as a pre-req for binary (closes: #329910)
+ - patch-121: Complete French translation
+ - patch-125: Fixed localization of y/n questions in German translation
+ (closes: #337078)
+ - patch-126: Swedish translation update (closes: #337163)
+ - patch-127: Complete Tagalog translation (closes: #337306)
+ - patch-128: Danish translation update (closes: #337949)
+ - patch-129: Basque translation update (closes: #338101)
+ * cmdline/apt-get.cc:
+ - bufix in FindSrc (closes: #335213, #337910)
+ * added armeb to archtable (closes: #333599)
+ * with --allow-unauthenticated use the old fallback behaviour for
+ sources (closes: #335112)
+
+ -- Michael Vogt <mvo@debian.org> Wed, 9 Nov 2005 07:22:31 +0100
+
+apt (0.6.42.2) unstable; urgency=high
+
+ * NMU (approved by maintainer)
+ * Add AMD64 archive signing key to debian-archive.gpg (closes: #336500).
+ * Add big-endian arm (armeb) support (closes: #333599).
+ * Priority high to get the AMD key into testing ASAP.
+
+ -- Frans Pop <fjp@debian.org> Sun, 30 Oct 2005 21:29:11 +0100
+
+apt (0.6.42.1) unstable; urgency=low
+
+ * fix a incorrect example in the apt_prefrences man page
+ (thanks to Filipus Klutiero, closes: #282918)
+ * apt-pkg/pkgrecords.cc:
+ - revert patch from last version, it causes trouble on alpha
+ and ia64 (closes: #335102, #335103)
+ * cmdline/apt-get.cc:
+ - be extra carefull in FindSrc (closes: #335213)
+
+ -- Michael Vogt <mvo@debian.org> Sat, 22 Oct 2005 23:44:35 +0200
+
+apt (0.6.42) unstable; urgency=low
+
+ * apt-pkg/cdrom.cc:
+ - unmount the cdrom when apt failed to locate any package files
+ * allow cdrom failures and fallback to other sources in that case
+ (closes: #44135)
+ * better error text when dpkg-source fails
+ * Merge bubulle@debian.org--2005/apt--main--0 up to patch-115:
+ - patch-99: Added Galician translation
+ - patch-100: Completed Danish translation (Closes: #325686)
+ - patch-104: French translation completed
+ - patch-109: Italian translation completed
+ - patch-112: Swedish translation update
+ - patch-115: Basque translation completed (Closes: #333299)
+ * applied french man-page update (thanks to Philippe Batailler)
+ (closes: #316638, #327456)
+ * fix leak in the mmap code, thanks to Daniel Burrows for the
+ patch (closes: #250583)
+ * support for apt-get [build-dep|source] -t (closes: #152129)
+ * added "APT::Authentication::TrustCDROM" option to make the life
+ for the installer people easier (closes: #334656)
+ * fix crash in apt-ftparchive (thanks to Bastian Blank for the patch)
+ (closes: #334671)
+ * apt-pkg/contrib/md5.cc:
+ - fix a alignment problem on sparc64 that gives random bus errors
+ (thanks to Fabbione for providing a test-case)
+ * init the default ScreenWidth to 79 columns by default
+ (Closes: #324921)
+ * cmdline/apt-cdrom.cc:
+ - fix some missing gettext() calls (closes: #334539)
+ * doc/apt-cache.8.xml: fix typo (closes: #334714)
+
+ -- Michael Vogt <mvo@debian.org> Wed, 19 Oct 2005 22:02:09 +0200
+
apt (0.6.41) unstable; urgency=low
* improved the support for "error" and "conffile" reporting from
diff --git a/debian/compat b/debian/compat
index 00750edc0..7ed6ff82d 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-3
+5
diff --git a/debian/control b/debian/control
index 6d9418a46..3cba50acb 100644
--- a/debian/control
+++ b/debian/control
@@ -3,8 +3,8 @@ Section: admin
Priority: important
Maintainer: APT Development Team <deity@lists.debian.org>
Uploaders: Jason Gunthorpe <jgg@debian.org>, Adam Heath <doogie@debian.org>, Matt Zimmerman <mdz@debian.org>, Michael Vogt <mvo@debian.org>
-Standards-Version: 3.6.1
-Build-Depends: debhelper (>= 4.1.62), libdb4.2-dev, gettext (>= 0.12)
+Standards-Version: 3.6.2.2
+Build-Depends: debhelper (>= 5.0), libdb4.4-dev, gettext (>= 0.12)
Build-Depends-Indep: debiandoc-sgml, docbook-utils (>= 0.6.12-1)
Package: apt
@@ -13,8 +13,9 @@ Depends: ${shlibs:Depends}
Priority: important
Replaces: libapt-pkg-doc (<< 0.3.7), libapt-pkg-dev (<< 0.3.7)
Provides: ${libapt-pkg:provides}
+Recommends: debian-archive-keyring
Suggests: aptitude | synaptic | gnome-apt | wajig, dpkg-dev, apt-doc, bzip2, gnupg
-Section: base
+Section: admin
Description: Advanced front-end for dpkg
This is Debian's next generation front-end for the dpkg package manager.
It provides the apt-get utility and APT dselect method that provides a
diff --git a/debian/libapt-pkg-doc.doc-base.cache b/debian/libapt-pkg-doc.doc-base.cache
index b58b79bd1..59558dee8 100644
--- a/debian/libapt-pkg-doc.doc-base.cache
+++ b/debian/libapt-pkg-doc.doc-base.cache
@@ -4,7 +4,7 @@ Author: Jason Gunthorpe
Abstract: The APT Cache Specification describes the complete implementation
and format of the APT Cache file. The APT Cache file is a way for APT to
parse and store a large number of package files for display in the UI.
- It's primaryã design goal is to make display of a single package in the
+ It's primary design goal is to make display of a single package in the
tree very fast by pre-linking important things like dependencies and
provides. The specification doubles as documentation for one of the
in-memory structures used by the package library and the APT GUI.
diff --git a/debian/postinst b/debian/postinst
index 891792111..1588f5241 100755
--- a/debian/postinst
+++ b/debian/postinst
@@ -12,7 +12,10 @@ set -e
create_apt_conf ()
{
- cp /usr/share/doc/apt/examples/sources.list /etc/apt/sources.list
+ EXAMPLE_SOURCE=/usr/share/doc/apt/examples/sources.list
+ if [ -f $EXAMPLE_SOURCE ]; then
+ cp $EXAMPLE_SOURCE /etc/apt/sources.list
+ fi
}
check_apt_conf ()
diff --git a/debian/rules b/debian/rules
index cd026b4a4..02ee734bb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -36,8 +36,9 @@ endif
# Default rule
build:
+PKG=apt
DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
-APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
+APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' -e 's/\+.*$$//')
APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
@@ -335,6 +336,6 @@ cvs-mkul:
arch-build:
rm -rf debian/arch-build
mkdir -p debian/arch-build/apt-$(APT_DEBVER)
- baz inventory -s | xargs cp -a --parents --target=debian/arch-build/apt-$(APT_DEBVER)
+ tar -c --exclude=arch-build --no-recursion -f - `bzr inventory` | (cd debian/arch-build/$(PKG)-$(APT_DEBVER);tar xf -)
$(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
(cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG))