summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2007-07-14 16:13:23 +0100
committerMichael Vogt <michael.vogt@ubuntu.com>2007-07-14 16:13:23 +0100
commit82d0afc286514bbe8904c3436bb6580aeaa6ad66 (patch)
tree2339856c9d735d6a228759d15b5e7258b98b0599 /debian
parentf03dd1e032139356f1e5b7f19fb76482ae05e311 (diff)
parente53ee4caf5ecf882e3df2665a8e1c2a9e6da6fb0 (diff)
* Simplified HttpMethod::Fetch on http.cc removing Tail variable;
* Fix pipeline handling on http.cc (closes: #413324) * Fix building to properly support binNMUs. Thanks to Daniel Schepler <schepler@math.unipd.it> by the patch (closes: #359634) * Fix example for Install-{Recommends,Suggests} options on configure-index example file. Thanks to Peter Eisentraut <peter_e@gmx.net> by the patch (closes: #432223)
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/rules2
2 files changed, 9 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index d18c19d0c..f618b84df 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,7 @@ apt (0.7.4) UNRELEASED; urgency=low
* cmdline/apt-get.cc:
- fix in the task-install code regexp (thanks to Adam Conrad and
Colin Watson)
+
[Otavio Salvador]
* Fix a typo on 0.7.3 changelog entry about g++ (7.3 to 4.3)
* Fix compilation warnings:
@@ -14,6 +15,13 @@ apt (0.7.4) UNRELEASED; urgency=low
- type conversion;
- unused variable;
- changed SetupProxy() method to void;
+ * Simplified HttpMethod::Fetch on http.cc removing Tail variable;
+ * Fix pipeline handling on http.cc (closes: #413324)
+ * Fix building to properly support binNMUs. Thanks to Daniel Schepler
+ <schepler@math.unipd.it> by the patch (closes: #359634)
+ * Fix example for Install-{Recommends,Suggests} options on
+ configure-index example file. Thanks to Peter Eisentraut
+ <peter_e@gmx.net> by the patch (closes: #432223)
-- Michael Vogt <michael.vogt@ubuntu.com> Wed, 11 Jul 2007 23:20:15 +0100
diff --git a/debian/rules b/debian/rules
index 3ebecfba4..473821f16 100755
--- a/debian/rules
+++ b/debian/rules
@@ -38,7 +38,7 @@ build:
PKG=apt
DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
-APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' -e 's/\+.*$$//')
+APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')