summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authormartin@piware.de <>2010-06-11 10:01:27 +0200
committermartin@piware.de <>2010-06-11 10:01:27 +0200
commitfdd739c74dcf266a7cb2f3688ea11afec4055f2c (patch)
treedd76a6d78b34f87be5d7ca63f2ad037861b06e8d /debian
parent31e1187be48846395cb3b57f0e9a731261a1484c (diff)
* debian/rules:
- Make DEB_BUILD_OPTIONS=noopt actually work by passing the right CXXFLAGS.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rwxr-xr-xdebian/rules2
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index bd328fd08..483fff9c3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,9 @@ apt (0.7.26~exp5) UNRELEASED; urgency=low
* Italian translation update. Closes: #581742
[ Martin Pitt ]
+ * debian/rules:
+ - Make DEB_BUILD_OPTIONS=noopt actually work by passing the right
+ CXXFLAGS.
* apt-pkg/contrib/fileutl.{h,cc}:
- Add support for transparent reading of gzipped files.
- Link against zlib (in apt-pkg/makefile) and add zlib build dependency.
diff --git a/debian/rules b/debian/rules
index 7677708b2..450f3e0f6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -108,7 +108,7 @@ build/configure-stamp: configure
dh_testdir
-mkdir build
cp COPYING debian/copyright
- cd build && CXXFLAGS="$(confcxxflags)" ../configure $(confflags)
+ cd build && CXXFLAGS="$(CXXFLAGS)" ../configure $(confflags)
touch $@
build/build-stamp: build/configure-stamp