summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <egon@debian-devbox>2013-03-01 12:06:50 +0100
committerMichael Vogt <egon@debian-devbox>2013-03-01 12:06:50 +0100
commit01b810674a34e30eb8bb913b94351cdaccd57e1c (patch)
tree93b684196c659d2b61bf256ec8eb99eea543e867 /debian
parentca3965066270db678649ffd19479a157d95b429f (diff)
parent0597dcd8fa8f933d8bf0d7fbea395408bf3b7e5d (diff)
merged from the debian-sid branch
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily2
-rw-r--r--debian/changelog27
-rwxr-xr-xdebian/rules2
3 files changed, 29 insertions, 2 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 5c00f22db..2665b6579 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -289,7 +289,7 @@ random_sleep()
fi
if [ -z "$RANDOM" ] ; then
# A fix for shells that do not have this bash feature.
- RANDOM=$(dd if=/dev/urandom count=1 2> /dev/null | cksum | cut -c"1-5")
+ RANDOM=$(( $(dd if=/dev/urandom bs=2 count=1 2> /dev/null | cksum | cut -d' ' -f1) % 32767 ))
fi
TIME=$(($RANDOM % $RandomSleep))
debug_echo "sleeping for $TIME seconds"
diff --git a/debian/changelog b/debian/changelog
index 6f611f2f5..9f4dca04e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -25,11 +25,38 @@ apt (0.9.7.8) UNRELEASED; urgency=low
[ Manpages translation updates ]
* Italian (Beatrice Torracca). Closes: #696601
+ [ Programs translation updates ]
+ * Japanese (Kenshi Muto). Closes: #699783
+
[ Michael Vogt ]
* fix pkgProblemResolver::Scores, thanks to Paul Wise.
Closes: #697577
* [ABI BREAK] apt-pkg/pkgcache.h:
- adjust pkgCache::State::VerPriority enum, to match reality
+ * fix missing translated apt.8 manpages, thanks to Helge Kreutzmann
+ for the report. Closes: #696923
+ * apt-pkg/contrib/progress.cc:
+ - Make "..." translatable to fix inconsistencies in the output
+ of e.g. apt-get update. While this adds new translatable strings,
+ not having translations for them will not break anything.
+ Thanks to Guillem Jover. Closes: #696225
+ * debian/apt.cron.daily:
+ - when reading from /dev/urandom, use less entropy and fix a rare
+ bug when the random number chksum is less than 1000.
+ Closes: #695285
+ * methods/https.cc:
+ - reuse connection in https, thanks to Thomas Bushnell, BSG for the
+ patch. LP: #1087543, Closes: #695359
+ - add missing curl_easy_cleanup()
+ * methods/http.cc:
+ - quote spaces in filenames to ensure as the http method is also
+ (potentially) used for non deb,dsc content that may contain
+ spaces, thanks to Daniel Hartwig and Thomas Bushnell
+ (LP: #1086997)
+ - quote plus in filenames to work around a bug in the S3 server
+ (LP: #1003633)
+ * apt-pkg/indexrecords.cc:
+ - support '\r' in the Release file
-- Christian Perrier <bubulle@debian.org> Mon, 24 Dec 2012 07:01:20 +0100
diff --git a/debian/rules b/debian/rules
index 83e23881c..5051dab4f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -172,7 +172,7 @@ apt-doc: build-debiandoc
# Build architecture-dependent files here.
binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
-apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
+apt_MANPAGES = apt apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
apt: build build-manpages
dh_testdir -p$@
dh_testroot -p$@