summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorArch Librarian <arch@canonical.com>2004-09-20 17:03:06 +0000
committerArch Librarian <arch@canonical.com>2004-09-20 17:03:06 +0000
commit47337f807e3feb6227ad172940520b303ec82241 (patch)
tree8c3c21f0c67fdc92d63ab989f564e2144ed8cd24 /debian
parent59a209f3c1ffa0a3f6d3a8dbf412324240e8a5a9 (diff)
* Move dh_makeshlibs ahead of dh_installdeb so that its...
Author: mdz Date: 2003-08-10 23:54:57 GMT * Move dh_makeshlibs ahead of dh_installdeb so that its postinst fragments are properly substituted
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rwxr-xr-xdebian/rules6
2 files changed, 6 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index a2ec41a88..193d7779b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -51,8 +51,10 @@ apt (0.5.9) unstable; urgency=low
* Build-depend on debhelper >= 4.1.62, because we need the fix for
#204731 in order for dh_installman to work correctly
with our SGML man pages
+ * Move dh_makeshlibs ahead of dh_installdeb so that its postinst
+ fragments are properly substituted
- -- Matt Zimmerman <mdz@debian.org> Sun, 10 Aug 2003 01:26:59 -0400
+ -- Matt Zimmerman <mdz@debian.org> Sun, 10 Aug 2003 19:54:39 -0400
apt (0.5.8) unstable; urgency=medium
diff --git a/debian/rules b/debian/rules
index bf097773e..9f13f7124 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,7 +2,7 @@
# Made with the aid of dh_make, by Craig Small
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.53 2003/08/09 19:21:33 mdz Exp $
+# $Id: rules,v 1.54 2003/08/10 23:54:57 mdz Exp $
# LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
# dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
@@ -218,10 +218,10 @@ apt: build debian/shlibs.local
dh_strip -p$@
dh_compress -p$@
dh_fixperms -p$@
+ dh_makeshlibs -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)' -papt
dh_installdeb -p$@
dh_shlibdeps -papt -l`pwd`/debian/apt/usr/lib -- -Ldebian/shlibs.local.apt
dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
- dh_makeshlibs -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)' -papt
dh_md5sums -p$@
dh_builddeb -p$@
@@ -274,10 +274,10 @@ apt-utils: build debian/shlibs.local
dh_strip -p$@
dh_compress -p$@
dh_fixperms -p$@
+ dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
dh_installdeb -p$@
LD_LIBRARY_PATH=$$LD_LIBRARY_PATH:`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib dh_shlibdeps -p$@ -- -Ldebian/shlibs.local.apt-utils
dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
- dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
dh_md5sums -p$@
dh_builddeb -p$@