summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2007-07-12 14:05:12 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2007-07-12 14:05:12 -0300
commitda78c57f0b0d96c8e76059971e31a7551510bde6 (patch)
tree04ca469d38aae6eae0ee84ca13c76b785c0f2c2d /debian
parenta99e1914169e0dfb1367d5a04a4611ead9839d02 (diff)
* Fix building to properly support binNMUs. Thanks to Daniel Schepler
<schepler@math.unipd.it> by the patch (closes: #359634)
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rwxr-xr-xdebian/rules2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 6e74f4265..5a810273f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -16,6 +16,8 @@ apt (0.7.4) UNRELEASED; urgency=low
- changed SetupProxy() method to void;
* Simplified HttpMethod::Fetch on http.cc removing Tail variable;
* Fix pipeline handling on http.cc (closes: #413324)
+ * Fix building to properly support binNMUs. Thanks to Daniel Schepler
+ <schepler@math.unipd.it> by the patch (closes: #359634)
-- Michael Vogt <michael.vogt@ubuntu.com> Wed, 11 Jul 2007 23:20:15 +0100
diff --git a/debian/rules b/debian/rules
index 3ebecfba4..473821f16 100755
--- a/debian/rules
+++ b/debian/rules
@@ -38,7 +38,7 @@ build:
PKG=apt
DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
-APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' -e 's/\+.*$$//')
+APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')