summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2005-02-08 15:33:23 +0000
committerMichael Vogt <michael.vogt@ubuntu.com>2005-02-08 15:33:23 +0000
commit8501516a89c1f333f7bc3866b05b5ce7fbf4e177 (patch)
tree023d64f1d1a53e9657e32e2a54664bf2beed9ede /debian
parentd3fbe3fe7968190312c953ee7ba0c567be33ef09 (diff)
parent8a57929175a93466c83a8e697ad876b60b2eb3c2 (diff)
* merged with matt's tree
Patches applied: * apt@packages.debian.org/apt--main--0--patch-52 0.6.31 * apt@packages.debian.org/apt--main--0--patch-53 Remove debugging from apt.cron.daily * apt@packages.debian.org/apt--main--0--patch-54 allow SHA1Summation to process a file descriptor until EOF * apt@packages.debian.org/apt--main--0--patch-55 Fix syntax in sha1.cc * apt@packages.debian.org/apt--main--0--patch-56 Fix build/install of Polish offline documentation * apt@packages.debian.org/apt--main--0--patch-57 Move CD-ROM handling backend into libapt-pkg * apt@packages.debian.org/apt--main--0--patch-58 Fix compilation errors from apt--auth-cdrom--0 * michael.vogt@ubuntu.com--2005/apt--auth-cdrom--0--base-0 tag of apt@packages.debian.org/apt--main--0--patch-51 * michael.vogt@ubuntu.com--2005/apt--auth-cdrom--0--patch-1 * added support for signed cdroms * michael.vogt@ubuntu.com--2005/apt--auth-cdrom--0--patch-2 * merged with apt--main, seperated cmdline/apt-cdrom.cc into a library (apt-pkg/cdrom.{cc,h}) * michael.vogt@ubuntu.com--2005/apt--auth-cdrom--0--patch-3 * cleaned up the cmdline/apt-cdrom.cc code
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily1
-rw-r--r--debian/changelog15
-rwxr-xr-xdebian/rules4
3 files changed, 17 insertions, 3 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 17fe8fb78..3e6b384d2 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -20,7 +20,6 @@ check_stamp()
stamp=$(date --date=$(date -r $stamp --iso-8601) +%s)
now=$(date --date=$(date --iso-8601) +%s)
delta=$(($now-$stamp))
- echo "stamp=$stamp, now=$now, delta=$delta"
if [ $delta -ge $interval ]; then
return 0
diff --git a/debian/changelog b/debian/changelog
index b98ecbf81..c384c399d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,18 @@
+apt (0.6.31) hoary; urgency=low
+
+ * Matt Zimmerman
+ - Remove debugging output from apt.cron.daily (no one noticed?)
+ - Apply patch from Anthony Towns to allow SHA1Summation to process a file
+ descriptor until EOF, rather than requiring that the length of input be
+ specified (Closes: #291338)
+ - Fix build/install of Polish offline documentation, based on patch from
+ Christian Perrier (Closes: #270404)
+ * Michael Vogt
+ - apt-cdrom.cc seperated into frontend (cmdline/apt-cdrom.cc and library
+ apt-pkg/cdrom.{cc,h}) (Ubuntu #5668)
+
+ -- Matt Zimmerman <mdz@ubuntu.com> Fri, 4 Feb 2005 10:23:01 -0800
+
apt (0.6.30) unstable; urgency=low
* Add ppc64 to buildlib/archtable
diff --git a/debian/rules b/debian/rules
index 71d6d549e..e3254c2d2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -36,7 +36,7 @@ endif
# Default rule
build:
-DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEBUILD_DPKG_BUILDPACKAGE_OPTS)
+DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
@@ -171,7 +171,7 @@ apt-doc: build-doc
#
# Copy the guides
dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
- $(BLD)/docs/offline.text $(BLD)/docs/offline.html
+ $(BLD)/docs/offline*.text $(BLD)/docs/offline*.html
dh_installchangelogs -p$@
dh_compress -p$@
dh_fixperms -p$@