summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorArch Librarian <arch@canonical.com>2004-09-20 17:06:46 +0000
committerArch Librarian <arch@canonical.com>2004-09-20 17:06:46 +0000
commitc6baaffe42212ac07d3faf126b67f84ec59066fd (patch)
treea10b10a67d048d61a19611cef9338699f2c4f8c0 /debian
parent2cbcabd888a1ae24091db36df6cdf5fa66e3c341 (diff)
* Modify debian/rules cvs-build to use cvs export, to a...
Author: mdz Date: 2004-05-08 19:52:33 GMT * Modify debian/rules cvs-build to use cvs export, to avoid picking up junk files from the working directory
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rwxr-xr-xdebian/rules15
2 files changed, 12 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index 83772e106..472cf6554 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -21,6 +21,8 @@ apt (0.5.25) unstable; urgency=low
- Add note to NEWS.Debian about upgrading old databases
* Attempt to fix problems with chunked encoding by stripping only a single CR
(Closes: #152711)
+ * Modify debian/rules cvs-build to use cvs export, to avoid picking up
+ junk files from the working directory
* Translation updates:
- Updated Swedish translation from Peter Karlsson <peter@softwolves.pp.se>
(Closes: #238943)
@@ -47,7 +49,7 @@ apt (0.5.25) unstable; urgency=low
- Updated Danish translation from Claus Hindsgaul <claus_h@image.dk>
(Closes: #247311)
- -- Matt Zimmerman <mdz@debian.org> Sat, 8 May 2004 12:42:23 -0700
+ -- Matt Zimmerman <mdz@debian.org> Sat, 8 May 2004 12:52:20 -0700
apt (0.5.24) unstable; urgency=low
diff --git a/debian/rules b/debian/rules
index d4d2fb61c..ebb230b9e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,7 +2,7 @@
# Made with the aid of dh_make, by Craig Small
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.65 2004/04/30 04:37:47 mdz Exp $
+# $Id: rules,v 1.66 2004/05/08 19:52:33 mdz Exp $
# LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
# dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
@@ -39,6 +39,7 @@ build:
DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc
APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
+APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
# Determine the build directory to use
BASE=.
@@ -312,14 +313,16 @@ binary: binary-indep binary-arch
# edit configure.in
# debian/rules cvs-build
+CVS_BUILDDIR=apt-$(APT_DEBVER)
+CVS_ROOT=$(shell cat CVS/Root)
+CVS_MODULE=$(shell cat CVS/Repository)
cvs-build:
rm -rf debian/cvs-build
cvs update -d
- $(MAKE) startup
- $(MAKE) doc
- tar c --exclude CVS --exclude cvs-build --exclude '.#*' . |\
- (mkdir -p debian/cvs-build/apt-$(APT_DEBVER);cd debian/cvs-build/apt-$(APT_DEBVER);tar x)
- (cd debian/cvs-build/apt-$(APT_DEBVER);$(DEB_BUILD_PROG))
+ mkdir -p debian/cvs-build
+ (cd debian/cvs-build;cvs -d $(CVS_ROOT) export -r$(APT_CVSTAG) -d apt-$(APT_DEBVER) $(CVS_MODULE))
+ $(MAKE) -C debian/cvs-build/$(CVS_BUILDDIR) startup doc
+ (cd debian/cvs-build/$(CVS_BUILDDIR);$(DEB_BUILD_PROG))
cvs-mkul:
-mkdir -p ../upload-$(APT_DEBVER)