summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <egon@bottom>2006-05-08 18:45:43 +0200
committerMichael Vogt <egon@bottom>2006-05-08 18:45:43 +0200
commitcfde4904a7b61e2a3c75322a08a6fac3c062d65d (patch)
tree83295f359aa7054578e4e776f0fe22f294f6f5d2 /debian
parent75e94aee76df0256eea7fbd8558437b93af28347 (diff)
parentfc5f54175a514c31c9400d9f9d08e6496cf63823 (diff)
* merged from mainline
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog13
-rw-r--r--debian/libapt-pkg-doc.doc-base.cache2
-rwxr-xr-xdebian/postinst5
3 files changed, 16 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 6d2a7173a..c9f410788 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -18,8 +18,17 @@ apt (0.6.44) unstable; urgency=low
* doc/apt-ftparchive.1.xml:
- fix documentation for "SrcPackages" -> "Sources"
(thanks to Bart Martens for the patch, closes: #307756)
-
- -- Michael Vogt <mvo@debian.org> Sun, 2 Apr 2006 16:41:54 +0200
+ * debian/libapt-pkg-doc.doc-base.cache:
+ - remove broken charackter from description (closes: #361129)
+ * apt-inst/deb/dpkgdb.cc, methods/gpgv.cc:
+ - i18n fixes (closes: #349298)
+ * debian/postinst: dont fail on not available
+ /usr/share/doc/apt/examples/sources.list (closes: #361130)
+ * methods/ftp.cc:
+ - unlink empty file in partial if the download failed because
+ the file is missing on the server (closes: #316337)
+
+ -- Michael Vogt <mvo@debian.org> Mon, 8 May 2006 18:41:04 +0200
apt (0.6.43.3) unstable; urgency=low
diff --git a/debian/libapt-pkg-doc.doc-base.cache b/debian/libapt-pkg-doc.doc-base.cache
index b58b79bd1..59558dee8 100644
--- a/debian/libapt-pkg-doc.doc-base.cache
+++ b/debian/libapt-pkg-doc.doc-base.cache
@@ -4,7 +4,7 @@ Author: Jason Gunthorpe
Abstract: The APT Cache Specification describes the complete implementation
and format of the APT Cache file. The APT Cache file is a way for APT to
parse and store a large number of package files for display in the UI.
- It's primaryć design goal is to make display of a single package in the
+ It's primary design goal is to make display of a single package in the
tree very fast by pre-linking important things like dependencies and
provides. The specification doubles as documentation for one of the
in-memory structures used by the package library and the APT GUI.
diff --git a/debian/postinst b/debian/postinst
index 891792111..1588f5241 100755
--- a/debian/postinst
+++ b/debian/postinst
@@ -12,7 +12,10 @@ set -e
create_apt_conf ()
{
- cp /usr/share/doc/apt/examples/sources.list /etc/apt/sources.list
+ EXAMPLE_SOURCE=/usr/share/doc/apt/examples/sources.list
+ if [ -f $EXAMPLE_SOURCE ]; then
+ cp $EXAMPLE_SOURCE /etc/apt/sources.list
+ fi
}
check_apt_conf ()