summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2007-09-14 14:32:02 +0200
committerMichael Vogt <michael.vogt@ubuntu.com>2007-09-14 14:32:02 +0200
commit821c6533d7ead7ec2e4832e6b3a980cd83c76754 (patch)
tree49d3267affcb4221b6cb744a31f34ec93697bc20 /debian
parent12121baed79ed5f47020b495519b68d1c37e0123 (diff)
parent9efa2e916d134e5960351cc3b67f4556ec4b2126 (diff)
* debian/apt.cron.daily:
- move unattended-upgrade before apt-get autoclean * fix "purge" commandline argument, closes LP: #125733 (thanks to Julien Danjou for the patch) * fix missing SetExecClose() call when the status-fd is used * debian/apt.cron.daily: - move unattended-upgrade before apt-get autoclean * fix "purge" commandline argument, closes: #133421 (thanks to Julien Danjou for the patch)
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily12
-rw-r--r--debian/changelog9
2 files changed, 15 insertions, 6 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 778e3cefe..34d6b164f 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -186,17 +186,17 @@ if check_stamp $DOWNLOAD_UPGRADEABLE_STAMP $DownloadUpgradeableInterval; then
update_stamp $DOWNLOAD_UPGRADEABLE_STAMP
fi
-AUTOCLEAN_STAMP=/var/lib/apt/periodic/autoclean-stamp
-if check_stamp $AUTOCLEAN_STAMP $AutocleanInterval; then
- apt-get -qq autoclean
- update_stamp $AUTOCLEAN_STAMP
-fi
-
UPGRADE_STAMP=/var/lib/apt/periodic/upgrade-stamp
if check_stamp $UPGRADE_STAMP $UnattendedUpgradeInterval; then
unattended-upgrade
update_stamp $UPGRADE_STAMP
fi
+AUTOCLEAN_STAMP=/var/lib/apt/periodic/autoclean-stamp
+if check_stamp $AUTOCLEAN_STAMP $AutocleanInterval; then
+ apt-get -qq autoclean
+ update_stamp $AUTOCLEAN_STAMP
+fi
+
# check cache size
check_size_constraints
diff --git a/debian/changelog b/debian/changelog
index f811a4c0c..c1b1f5676 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,10 @@ apt (0.7.6ubuntu9) gutsy; urgency=low
* make apt build with g++ 4.3
* fix missing SetExecClose() call when the status-fd is used
(LP: #136767)
+ * debian/apt.cron.daily:
+ - move unattended-upgrade before apt-get autoclean
+ * fix "purge" commandline argument, closes LP: #125733
+ (thanks to Julien Danjou for the patch)
-- Michael Vogt <michael.vogt@ubuntu.com> Tue, 11 Sep 2007 20:55:00 +0200
@@ -95,6 +99,11 @@ apt (0.7.6ubuntu1) gutsy; urgency=low
* tests/local-repo:
- added local repository testcase
* make apt build with g++ 4.3
+ * fix missing SetExecClose() call when the status-fd is used
+ * debian/apt.cron.daily:
+ - move unattended-upgrade before apt-get autoclean
+ * fix "purge" commandline argument, closes: #133421
+ (thanks to Julien Danjou for the patch)
[ Ian Jackson ]
* dpkg-triggers: Deal properly with new package states.