summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorArch Librarian <arch@canonical.com>2004-09-20 16:56:34 +0000
committerArch Librarian <arch@canonical.com>2004-09-20 16:56:34 +0000
commit1156d969749480f1fbe6c5d37dcd54e6ac411cb9 (patch)
tree53b58a4b82cff5183d3a789493c3f702bcd51ec1 /debian
parent69adf430b85fe700a1093d76abeb06e5f112ecfa (diff)
0.5.0 readyness
Author: jgg Date: 2001-02-21 04:25:20 GMT 0.5.0 readyness
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/postrm2
-rwxr-xr-xdebian/preinst2
-rwxr-xr-xdebian/prerm2
-rwxr-xr-xdebian/rules8
4 files changed, 10 insertions, 4 deletions
diff --git a/debian/postrm b/debian/postrm
index b1bb971d4..bc6fa2890 100755
--- a/debian/postrm
+++ b/debian/postrm
@@ -8,6 +8,8 @@
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
+#DEBHELPER#
+
case "$1" in
purge)
echo -n "Removing APT cache and state files... "
diff --git a/debian/preinst b/debian/preinst
index 141db6e45..276eae5de 100755
--- a/debian/preinst
+++ b/debian/preinst
@@ -26,3 +26,5 @@ if [ "$1" = "upgrade" -o "$1" = "install" -a "$2" != "" ]; then
fi
touch /var/lib/apt/lists/partial/.delete-me-later || true
fi
+
+#DEBHELPER#
diff --git a/debian/prerm b/debian/prerm
index 64b3635c5..ac70a0279 100755
--- a/debian/prerm
+++ b/debian/prerm
@@ -1,5 +1,7 @@
#! /bin/sh
+#DEBHELPER#
+
if [ "$1" = "upgrade" -o "$1" = "failed-upgrade" ] &&
dpkg --compare-versions "$2" "<<" 0.4.10
then
diff --git a/debian/rules b/debian/rules
index 13912e9f7..7c25a6618 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,7 +2,7 @@
# Made with the aid of dh_make, by Craig Small
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.24 2001/02/20 07:03:17 jgg Exp $
+# $Id: rules,v 1.25 2001/02/21 04:25:20 jgg Exp $
# LD_LIBRARY_PATH=pwd/debian/tmp/usr/lib dh_shlibdeps -papt
# dpkg: /home/jgg/work/apt2/debian/tmp/usr/lib/libapt-pkg.so.2.9 not found.
@@ -279,15 +279,15 @@ binary: binary-indep binary-arch
cvs-build:
rm -rf debian/cvs-build
cvs update
- buildlib/mkChangeLog
+ #buildlib/mkChangeLog
$(MAKE) startup
$(MAKE) doc
- tar c --exclude CVS --exclude debian/cvs-build . |\
+ tar c --exclude CVS --exclude cvs-build . |\
(mkdir -p debian/cvs-build/apt-$(APT_DEBVER);cd debian/cvs-build/apt-$(APT_DEBVER);tar x)
# The next line isn't needed, as debuild will make the .tar.gz for us.
# (cd debian/cvs-build;tar zcf apt_$(APT_DEBVER).tar.gz apt-$(APT_DEBVER))
(cd debian/cvs-build/apt-$(APT_DEBVER);$(DEB_BUILD_PROG))
- rm ChangeLog
+ #rm ChangeLog
cvs-mkul:
-mkdir -p ../upload-$(APT_DEBVER)