summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2008-06-03 17:01:06 +0200
committerMichael Vogt <michael.vogt@ubuntu.com>2008-06-03 17:01:06 +0200
commit2783b2615aa3ed0bf6969c3571fb058a00677645 (patch)
tree6e16bc9cb5baca14a779616cb0b9102ec0e8c29e /debian
parentbe993931c56d0d435e03c80f3afcc31714aec1ba (diff)
parentc5fdf360513f8d2e5858711ff46c744cddcdeb6f (diff)
merged from the debian-sid branch
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily11
-rw-r--r--debian/changelog19
2 files changed, 25 insertions, 5 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index cdb970521..472d20c6d 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -136,6 +136,7 @@ if [ "$VERBOSE" -ge 3 ]; then
# trace output
set -x
fi
+
# laptop check, on_ac_power returns:
# 0 (true) System is on main power
# 1 (false) System is not on main power
@@ -233,6 +234,16 @@ for x in $(seq 0 1 $((${BackupLevel}-1))); do
eval "Back${x}=${Back}${x}/"
done
+# check if we actually have to do anything
+if [ $UpdateInterval -eq 0 ] &&
+ [ $DownloadUpgradeableInterval -eq 0 ] &&
+ [ $UnattendedUpgradeInterval -eq 0 ] &&
+ [ $BackupArchiveInterval -eq 0 ] &&
+ [ $AutocleanInterval -eq 0 ]; then
+ exit 0
+fi
+
+
# backup after n-days if archive contents changed.
# (This uses hardlink to save disk space)
BACKUP_ARCHIVE_STAMP=/var/lib/apt/periodic/backup-archive-stamp
diff --git a/debian/changelog b/debian/changelog
index 483e4e7e8..f3c82dd4a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,11 @@
-apt (0.7.14) UNRELEASED; urgency=low
+apt (0.7.15) UNRELEASED; urgency=low
+
+ [ Michael Vogt ]
+ * improve apt progress reporting, display trigger actions
+
+ --
+
+apt (0.7.14) unstable; urgency=low
[ Christian Perrier ]
* Mark a message from dselect backend as translatable
@@ -14,9 +21,6 @@ apt (0.7.14) UNRELEASED; urgency=low
* Documented all cron script related configuration items in
configure-index.
- [ Michael Vogt ]
- * improve apt progress reporting, display trigger actions
-
[ Program translations ]
* Simplified Chinese updated. Closes: #473360
* Catalan fixes. Closes: #387141
@@ -43,8 +47,13 @@ apt (0.7.14) UNRELEASED; urgency=low
* Apply patch to avoid truncating of arbitrary files. Thanks to Bryan
Donlan <bdonlan@fushizen.net> for the patch. Closes: #482476
* Avoid using dbus if dbus-daemon isn't running. Closes: #438803
+
+ [ Michael Vogt ]
+ * debian/apt.cron.daily:
+ - apply patch based on the ideas of Francesco Poli for better
+ behavior when the cache can not be locked (closes: #459344)
- -- Christian Perrier <bubulle@debian.org> Sun, 04 May 2008 08:31:06 +0200
+ -- Michael Vogt <mvo@debian.org> Wed, 28 May 2008 15:19:12 +0200
apt (0.7.13) unstable; urgency=low