summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <mvo@debian.org>2010-07-12 13:26:10 +0200
committerMichael Vogt <mvo@debian.org>2010-07-12 13:26:10 +0200
commit2a679f4f71784800b6643b5c4eecb4b11865a439 (patch)
treec8b5f2967f09a3001becf5fb6ff634d933e171a2 /debian
parent137a73dc58b14f71a11da5940e099725f6dad8ef (diff)
parentd10cef824604012516f26efaae8bab1f29a7820a (diff)
merged from lp:~donkult/apt/sid
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog49
-rw-r--r--debian/control3
-rwxr-xr-xdebian/rules2
3 files changed, 52 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index a4ee9a7f8..0f87ce60f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,52 @@
+apt (0.7.26~exp10) experimental; urgency=low
+
+ [ David Kalnischkies ]
+ * apt-pkg/contrib/error.{cc,h}:
+ - remove constness of va_list parameter to fix build on amd64 and co
+ Thanks Eric Valette! (Closes: #588610)
+ * apt-pkg/deb/debmetaindex.cc:
+ - do not query each architecture for flat file archives
+ - fix typo preventing display of architecture in Info()
+ * methods/bzip2.cc:
+ - add a copycat of the old gzip.cc as we need it for bzip2 and lzma
+
+ [ Martin Pitt ]
+ * debian/rules:
+ - Make DEB_BUILD_OPTIONS=noopt actually work by passing the right
+ CXXFLAGS.
+ * apt-pkg/contrib/fileutl.{h,cc}:
+ - Add support for reading of gzipped files with the new "ReadOnlyGzip"
+ OpenMode. (Closes: #188407)
+ - Link against zlib (in apt-pkg/makefile) and add zlib build dependency.
+ - [ABI BREAK] This adds a new private member to FileFd, but its
+ initialization is in the public header file.
+ * configure.in:
+ - Check for zlib library and headers.
+ * apt-pkg/acquire-item.cc, apt-pkg/deb/debindexfile.cc,
+ apt-pkg/deb/debrecords.cc, apt-pkg/deb/debsrcrecords.h,
+ cmdline/apt-cache.cc:
+ - Open Packages, Sources, and Translations indexes in "ReadOnlyGzip" mode.
+ * apt-pkg/deb/debindexfile.cc:
+ - If we do not find uncompressed package/source/translation indexes, look
+ for gzip compressed ones.
+ * apt-pkg/acquire-item.cc:
+ - If the Acquire::GzipIndexes option is true and we download a gzipped
+ index file, keep it as it is (and rename to .gz) instead of
+ uncompressing it.
+ * doc/apt.conf.5.xml:
+ - Document the new Acquire::GzipIndexes option.
+ * doc/po/apt-doc.pot, doc/po/de.po:
+ - German translation of new Acquire::GzipIndexes option.
+ * Add test/test-indexes.sh:
+ - Test behaviour of index retrieval and usage, in particular with
+ uncompressed and gzip compressed indexes.
+ * methods/gzip.cc: With FileFd now being able to read gzipped files, there
+ is no need for the gzip method any more to spawn an external gzip process.
+ Rewrite it to use FileFd directly, which makes the code a lot simpler, and
+ also using less memory and overhead.
+
+ -- Michael Vogt <mvo@debian.org> Mon, 12 Jul 2010 11:41:01 +0200
+
apt (0.7.26~exp9) experimental; urgency=low
[ David Kalnischkies ]
diff --git a/debian/control b/debian/control
index d482f2d0b..757b761e5 100644
--- a/debian/control
+++ b/debian/control
@@ -6,8 +6,9 @@ Uploaders: Michael Vogt <mvo@debian.org>, Otavio Salvador <otavio@debian.org>,
Christian Perrier <bubulle@debian.org>, Daniel Burrows <dburrows@debian.org>,
Luca Bruno <lethalman88@gmail.com>, Julian Andres Klode <jak@debian.org>
Standards-Version: 3.9.0
-Build-Depends: debhelper (>= 5.0), libdb-dev, gettext (>= 0.12), libcurl4-gnutls-dev | libcurl3-gnutls-dev (>= 7.15.5), debiandoc-sgml, xsltproc, docbook-xsl, po4a (>= 0.34-2), autotools-dev, autoconf, automake, doxygen
+Build-Depends: debhelper (>= 5.0), libdb-dev, gettext (>= 0.12), libcurl4-gnutls-dev | libcurl3-gnutls-dev (>= 7.15.5), zlib1g-dev | libz-dev, debiandoc-sgml, xsltproc, docbook-xsl, po4a (>= 0.34-2), autotools-dev, autoconf, automake, doxygen
Build-Conflicts: autoconf2.13, automake1.4
+Vcs-Bzr: http://bzr.debian.org/apt/debian-sid/
Package: apt
Architecture: any
diff --git a/debian/rules b/debian/rules
index 0ac45f851..8bfcaf385 100755
--- a/debian/rules
+++ b/debian/rules
@@ -112,7 +112,7 @@ build/configure-stamp: configure
dh_testdir
-mkdir build
cp COPYING debian/copyright
- cd build && CXXFLAGS="$(confcxxflags)" ../configure $(confflags)
+ cd build && CXXFLAGS="$(CXXFLAGS)" ../configure $(confflags)
touch $@
build/build-stamp: build/configure-stamp