summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDavid Kalnischkies <kalnischkies@gmail.com>2010-05-24 12:09:45 +0200
committerDavid Kalnischkies <kalnischkies@gmail.com>2010-05-24 12:09:45 +0200
commit39151234858bb92d2e24ab367ebc14b363b4a48c (patch)
treea4206b720a6602ac0b05c9e194d0cdff148c849a /debian
parenta59397c121813583f5d43f70aa0a779bd0025477 (diff)
use dpkg-buildflags if available for CXXFLAGS
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rwxr-xr-xdebian/rules10
2 files changed, 8 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 6d7b62be0..a0adde726 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -13,6 +13,7 @@ apt (0.7.26~exp5) UNRELEASED; urgency=low
* debian/rules:
- remove targets referring to CVS or arch as they are useless
- use $(CURDIR) instead of $(pwd)
+ - use dpkg-buildflags if available for CXXFLAGS
* README.arch:
- remove the file completely as it has no use nowadays
* apt-pkg/depcache.cc:
diff --git a/debian/rules b/debian/rules
index f1cb77fbe..827fc2034 100755
--- a/debian/rules
+++ b/debian/rules
@@ -27,10 +27,14 @@ endif
# See below
-include build/environment.mak
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- export CXXFLAGS = -O0 -g -Wall
+ifneq (,$(shell which dpkg-buildflags))
+ export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
else
- export CXXFLAGS = -O2 -g -Wall
+ ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ export CXXFLAGS = -O0 -g -Wall
+ else
+ export CXXFLAGS = -O2 -g -Wall
+ endif
endif
# Default rule