summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <egon@bottom>2006-12-14 12:39:29 +0100
committerMichael Vogt <egon@bottom>2006-12-14 12:39:29 +0100
commit6ca714d55119e87a01bd475abd08e7212dcafbd0 (patch)
tree264c3a939b34f5daea19f45619686f060569f34d /debian
parent0660506d1916f6538359f238e860804441ba24f3 (diff)
parentdc4002d8c3c687e6614d01b34e4b6aa929411ea9 (diff)
* merged the apt-breaks-iwj branch
* pulled in the other remaining ubuntu changes
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily16
-rw-r--r--debian/changelog11
-rwxr-xr-xdebian/rules5
3 files changed, 32 insertions, 0 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 26dfa2530..b4cbf1c8a 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -14,6 +14,12 @@
# "APT::Periodic::AutocleanInterval"
# - Do "apt-get autoclean" every n-days (0=disable)
#
+# "APT::Periodic::Unattended-Upgrade"
+# - Run the "unattended-upgrade" security upgrade script
+# every n-days (0=disabled)
+# Requires the package "unattended-upgrades" and will write
+# a log in /var/log/unattended-upgrades
+#
# "APT::Archives::MaxAge",
# - Set maximum allowed age of a cache package file. If a cache
# package file is older it is deleted (0=disable)
@@ -148,6 +154,10 @@ eval $(apt-config shell UpdateInterval APT::Periodic::Update-Package-Lists Downl
AutocleanInterval=$DownloadUpgradeableInterval
eval $(apt-config shell AutocleanInterval APT::Periodic::Autoclean)
+UnattendedUpgradeInterval=0
+eval $(apt-config shell UnattendedUpgradeInterval APT::Periodic::Unattended-Upgrade)
+
+
# laptop check, on_ac_power returns:
# 0 (true) System is on mains power
# 1 (false) System is not on mains power
@@ -182,5 +192,11 @@ if check_stamp $AUTOCLEAN_STAMP $AutocleanInterval; then
update_stamp $AUTOCLEAN_STAMP
fi
+UPGRADE_STAMP=/var/lib/apt/periodic/upgrade-stamp
+if check_stamp $UPGRADE_STAMP $UnattendedUpgradeInterval; then
+ unattended-upgrade
+ update_stamp $UPGRADE_STAMP
+fi
+
# check cache size
check_size_constraints
diff --git a/debian/changelog b/debian/changelog
index 80c47bdee..52bdced8f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,17 @@ apt (0.7.0) experimental; urgency=low
* Branch that contains tall the new features
* Removed all #pragma interface/implementation
+ * Branch that contains tall the new features:
+ * translated package descriptions
+ * task install support
+ * automatic dependency removal
+ * Removed all #pragma interface/implementation
+ * merged support for the new dpkg "Breaks" field
+ (thanks to Ian Jackson)
+ * handle network failures more gracefully on "update"
+ * support for unattended-upgrades (via unattended-upgrades
+ package)
+
-- Michael Vogt <mvo@debian.org> Thu, 14 Dec 2006 11:31:41 +0100
diff --git a/debian/rules b/debian/rules
index 0413310a7..68302daff 100755
--- a/debian/rules
+++ b/debian/rules
@@ -214,6 +214,11 @@ apt: build debian/shlibs.local
cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
# head -n 500 ChangeLog > debian/ChangeLog
+ # make rosetta happy and remove pot files in po/ (but leave stuff
+ # in po/domains/* untouched) and cp *.po into each domain dir
+ rm -f build/po/*.pot
+ rm -f po/*.pot
+
dh_installexamples -p$@ $(BLD)/docs/examples/*
dh_installman -p$@
dh_installcron -p$@