summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <mvo@debian.org>2014-01-25 22:39:21 +0100
committerMichael Vogt <mvo@debian.org>2014-01-25 22:39:21 +0100
commit72af508bdbca55d0752aab3369faa1dc944a04e7 (patch)
tree933b60b160f1876990bb02bab20fcdb491c8b560 /debian
parentb52e8ce26ee0ee906f8bad4dbd72eca51fb65ed7 (diff)
parente093518c03b49a2def83d8b680be4490fed6e69c (diff)
Merge branch 'debian/sid' into ubuntu/master
Conflicts: configure.ac debian/changelog doc/apt-verbatim.ent doc/po/apt-doc.pot po/ar.po po/ast.po po/bg.po po/bs.po po/ca.po po/cs.po po/cy.po po/da.po po/de.po po/dz.po po/el.po po/es.po po/eu.po po/fi.po po/fr.po po/gl.po po/hu.po po/it.po po/ja.po po/km.po po/ko.po po/ku.po po/lt.po po/mr.po po/nb.po po/ne.po po/nl.po po/nn.po po/pl.po po/pt.po po/pt_BR.po po/ro.po po/ru.po po/sk.po po/sl.po po/sv.po po/th.po po/tl.po po/tr.po po/uk.po po/vi.po po/zh_CN.po po/zh_TW.po
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog31
-rwxr-xr-xdebian/rules1
-rw-r--r--debian/tests/run-tests17
3 files changed, 46 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 2cb9c2783..eb624a288 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,34 @@
+apt (0.9.14.2) unstable; urgency=low
+
+ [ Joe Hansen ]
+ * Danish translation update. Closes: #732166
+
+ [ Peter Green ]
+ * add apt-vendor for raspbian. Closes: #732749
+
+ [ Thomas Bechtold ]
+ * apt-pkg/contrib/gpgv.cc: use /tmp as fallback dir if the
+ directory from $TMPDIR is not available (closes: #728500)
+
+ [ Michael Vogt ]
+ * vendor/getinfo:
+ - fix ubuntu-codename
+ * vendor/steamos/*:
+ - add steamos support
+ * bugfix/bts731738-fancy-progess:
+ - fix terminal size issues with e.g. "less" when "APT::Progress-Fancy=1"
+ is used (closes: #731738)
+ * feature/policy-parser-bts732746:
+ - allow more flexibility in /etc/apt/preferences, e.g. comment only
+ sections (closes: #732746)
+ * move TMPDIR handling into GetTempDir() and use that instead of
+ getenv("TMPDIR")
+ * update apt-key net-update and add integration test with the buildin
+ apt webserver
+ * run autopkgtest against the installed apt
+
+ -- Michael Vogt <mvo@debian.org> Sun, 29 Dec 2013 16:41:16 +0100
+
apt (0.9.14.1ubuntu2) trusty; urgency=medium
* Install the apt binary.
diff --git a/debian/rules b/debian/rules
index 4fe81246b..ba9417e88 100755
--- a/debian/rules
+++ b/debian/rules
@@ -219,6 +219,7 @@ apt: build-binary build-manpages debian/apt.install
dh_strip -p$@
dh_compress -p$@
dh_fixperms -p$@
+ dh_makeshlibs -p$@
dh_installdeb -p$@
dh_shlibdeps -p$@
dh_gencontrol -p$@ -- -Vapt:keyring="$(shell ./vendor/getinfo keyring-package)"
diff --git a/debian/tests/run-tests b/debian/tests/run-tests
index 6ea503568..233c5a386 100644
--- a/debian/tests/run-tests
+++ b/debian/tests/run-tests
@@ -2,6 +2,17 @@
set -e
-make
-make test
-test/integration/run-tests
+# auto-package-test is very unhappy if stuff it writen to stderr
+exec 2> apt-stderr.log
+
+# we need the buildin webserver for the tests
+if [ ! -e environment.mak ]; then
+ ./configure
+fi
+make -C test/interactive-helper/
+
+# run against the installed apt
+APT_INTEGRATION_TESTS_WEBSERVER_BIN_DIR=$(pwd)/build/bin \
+APT_INTEGRATION_TESTS_METHODS_DIR=/usr/lib/apt/methods \
+APT_INTEGRATION_TESTS_BUILD_DIR=/usr/bin \
+./test/integration/run-tests