summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2007-08-03 15:01:05 +0200
committerMichael Vogt <michael.vogt@ubuntu.com>2007-08-03 15:01:05 +0200
commit7fc9db7c75948504393971681054c5dbea137c5d (patch)
treec0c188462ce8f5313f97a6c0ae35a25bef47d239 /debian
parent5b28c8040795b53a4df54f33e57976720558ed32 (diff)
parentc3279b9d100fb62f412267512458b58dda40f95b (diff)
* apt-inst/contrib/extracttar.cc:
- fix fd leak for zero size files (thanks to Bill Broadley for reporting this bug) * apt-pkg/acquire-item.cc: - remove zero size files on I-M-S hit * methods/https.cc: - only send LastModified if we actually have one - send range request with if-range - delete failed downloads * apt-pkg/deb/dpkgpm.{cc,h}: - merged dpkg-log branch, this lets you specify a Dir::Log::Terminal file to log dpkg output to (ABI break) * merged apt--sha256 branch to fully support the new sha256 checksums in the Packages and Release files (ABI break) * Applied patch from Aurelien Jarno <aurel32@debian.org> to fix wrong directory downloading on non-linux architectures (closes: #435597)
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.dirs2
-rw-r--r--debian/apt.logrotate8
-rw-r--r--debian/changelog30
-rwxr-xr-xdebian/rules1
4 files changed, 40 insertions, 1 deletions
diff --git a/debian/apt.dirs b/debian/apt.dirs
index 1543e8bb1..8ce9b175a 100644
--- a/debian/apt.dirs
+++ b/debian/apt.dirs
@@ -4,7 +4,9 @@ usr/lib/dpkg/methods/apt
etc/apt
etc/apt/apt.conf.d
etc/apt/sources.list.d
+etc/logrotate.d
var/cache/apt/archives/partial
var/lib/apt/lists/partial
var/lib/apt/periodic
+var/log/apt
usr/share/bug/apt
diff --git a/debian/apt.logrotate b/debian/apt.logrotate
new file mode 100644
index 000000000..3e924d383
--- /dev/null
+++ b/debian/apt.logrotate
@@ -0,0 +1,8 @@
+/var/log/apt/term.log {
+ rotate 6
+ monthly
+ compress
+ missingok
+ notifempty
+}
+
diff --git a/debian/changelog b/debian/changelog
index 873df1693..f5cf06c1e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,31 @@
+apt (0.7.7) UNRELEASED; urgency=low
+
+ * apt-inst/contrib/extracttar.cc:
+ - fix fd leak for zero size files (thanks to Bill Broadley for
+ reporting this bug)
+ * apt-pkg/acquire-item.cc:
+ - remove zero size files on I-M-S hit
+ * methods/https.cc:
+ - only send LastModified if we actually have one
+ - send range request with if-range
+ - delete failed downloads
+ * apt-pkg/deb/dpkgpm.{cc,h}:
+ - merged dpkg-log branch, this lets you specify a
+ Dir::Log::Terminal file to log dpkg output to
+ (ABI break)
+ * merged apt--sha256 branch to fully support the new
+ sha256 checksums in the Packages and Release files
+ (ABI break)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Thu, 02 Aug 2007 11:55:54 +0200
+
+apt (0.7.6) unstable; urgency=low
+
+ * Applied patch from Aurelien Jarno <aurel32@debian.org> to fix wrong
+ directory downloading on non-linux architectures (closes: #435597)
+
+ -- Otavio Salvador <otavio@debian.org> Wed, 01 Aug 2007 19:49:51 -0300
+
apt (0.7.6) unstable; urgency=low
* Applied patch from Aurelien Jarno <aurel32@debian.org> to fix wrong
@@ -391,7 +419,7 @@ apt (0.6.45) unstable; urgency=low
* apt-pkg/tagfile.cc:
- support not-mmapable files again
- -- Michael Vogt <michael.vogt@ubuntu.com> Tue, 25 Jul 2006 11:55:22 +0200
+ -- Michael Vogt <mvo@debian.org> Thu, 27 Jul 2006 00:52:05 +0200
apt (0.6.44.2exp1) experimental; urgency=low
diff --git a/debian/rules b/debian/rules
index 473821f16..b3222f3b4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -209,6 +209,7 @@ apt: build debian/shlibs.local
cp -r $(BLD)/locale debian/$@/usr/share/
cp debian/bugscript debian/$@/usr/share/bug/apt/script
+ cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
cp share/debian-archive.gpg debian/$@/usr/share/$@
cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove