summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorArch Librarian <arch@canonical.com>2004-09-20 16:56:59 +0000
committerArch Librarian <arch@canonical.com>2004-09-20 16:56:59 +0000
commit90ebe30ca5de782ebd4c8ee7c3a2d883a1444a2c (patch)
tree3c1e649872dd9c9f782de086769c087465f05d4f /debian
parentbcae6dd40485fce886c08c101d39226d6aba7022 (diff)
some packaging fixes
Author: tausq Date: 2001-03-04 03:21:50 GMT some packaging fixes
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules36
1 files changed, 19 insertions, 17 deletions
diff --git a/debian/rules b/debian/rules
index 2beeb35c8..65529eebf 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,10 +2,10 @@
# Made with the aid of dh_make, by Craig Small
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.27 2001/02/27 04:16:05 tausq Exp $
+# $Id: rules,v 1.28 2001/03/04 03:21:50 tausq Exp $
-# LD_LIBRARY_PATH=pwd/debian/tmp/usr/lib dh_shlibdeps -papt
-# dpkg: /home/jgg/work/apt2/debian/tmp/usr/lib/libapt-pkg.so.2.9 not found.
+# LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
+# dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
# For the deb builder, you can run 'debian/rules cvs-build', which does all
# steps nescessary to produce a proper source tarball with the CVS/ removed.
@@ -14,6 +14,8 @@
# create ../upload-<VER>, with all the files needed to be uploaded placed
# in it.
+export DH_COMPAT=3
+
# See below
include build/environment.mak
@@ -153,39 +155,39 @@ apt: build debian/shlibs.local
#
# apt install
#
- cp $(BLD)/bin/apt-* debian/tmp/usr/bin/
+ cp $(BLD)/bin/apt-* debian/apt/usr/bin/
# Remove the bits that are in apt-utils
- rm $(addprefix debian/tmp/usr/bin/apt-,$(APT_UTILS))
+ rm $(addprefix debian/apt/usr/bin/apt-,$(APT_UTILS))
# install the shared libs
- find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/tmp/usr/lib/ \;
- find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/tmp/usr/lib/ \;
+ find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
+ find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
- cp $(BLD)/bin/methods/* debian/tmp/usr/lib/apt/methods/
+ cp $(BLD)/bin/methods/* debian/apt/usr/lib/apt/methods/
- cp $(BLD)/scripts/dselect/* debian/tmp/usr/lib/dpkg/methods/apt/
+ cp $(BLD)/scripts/dselect/* debian/apt/usr/lib/dpkg/methods/apt/
# Copy the guides
dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
$(BLD)/docs/offline.text $(BLD)/docs/offline.html
# One or the other..
- -cp -a debian/dhelp debian/tmp/usr/doc/apt/.dhelp
- -cp -a debian/dhelp debian/tmp/usr/share/doc/apt/.dhelp
+ -cp -a debian/dhelp debian/apt/usr/doc/apt/.dhelp
+ -cp -a debian/dhelp debian/apt/usr/share/doc/apt/.dhelp
# head -n 500 ChangeLog > debian/ChangeLog
dh_installexamples -p$@ $(BLD)/docs/examples/*
- dh_installmanpages -p$@ apt-ftparchive.1 apt-sortpkgs.1
+ dh_installmanpages -p$@ apt-ftparchive.1 apt-sortpkgs.1 apt-extracttemplates.1
dh_installchangelogs -p$@
dh_strip -p$@
dh_compress -p$@
dh_fixperms -p$@
dh_installdeb -p$@
- dh_shlibdeps -papt -l`pwd`/debian/tmp/usr/lib -- -Ldebian/shlibs.local.apt
-# LD_LIBRARY_PATH=`pwd`/debian/tmp/usr/lib dh_shlibdeps -papt
+ dh_shlibdeps -papt -l`pwd`/debian/apt/usr/lib -- -Ldebian/shlibs.local.apt
+# LD_LIBRARY_PATH=`pwd`/debian/apt/usr/lib dh_shlibdeps -papt
dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
dh_makeshlibs -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)' -papt
dh_md5sums -p$@
@@ -235,14 +237,14 @@ apt-utils: build debian/shlibs.local
# Install the man pages..
mkdir -p debian/$@/usr/share/man/man1
- -cp doc/apt-sortpkgs.1 doc/apt-ftparchive.1 debian/$@/usr/share/man/man1/
-
+ -cp doc/apt-sortpkgs.1 doc/apt-ftparchive.1 doc/apt-extracttemplates.1 debian/$@/usr/share/man/man1/
+
dh_installchangelogs -p$@
dh_strip -p$@
dh_compress -p$@
dh_fixperms -p$@
dh_installdeb -p$@
- LD_LIBRARY_PATH=`pwd`/debian/tmp/usr/lib:`pwd`/debian/$@/usr/lib dh_shlibdeps -p$@ -- -Ldebian/shlibs.local.apt-utils
+ LD_LIBRARY_PATH=`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib dh_shlibdeps -p$@ -- -Ldebian/shlibs.local.apt-utils
dh_gencontrol -p$@ -u -Vlibapt-inst:major=$(LIBAPTINST_MAJOR)
dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
dh_md5sums -p$@