summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2016-09-02 22:38:34 +0200
committerJulian Andres Klode <jak@debian.org>2016-09-02 22:38:34 +0200
commit969d33307ae0cc1b433a0462ef1561580ea6ddbc (patch)
tree0322cf6e3a82a1536c4516e8729993ce68af57af /debian
parentf6c10fb46d1193b8181b5846538e2cf7c15ff216 (diff)
parent54dd6baaf16e92c83f63bdb3633df6e603ac19f3 (diff)
Merge tag '1.3_rc4' into ubuntu/master
apt Debian release 1.3~rc4
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.dirs1
-rw-r--r--debian/changelog21
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules3
4 files changed, 27 insertions, 0 deletions
diff --git a/debian/apt.dirs b/debian/apt.dirs
index bdc5adddb..54adcaa05 100644
--- a/debian/apt.dirs
+++ b/debian/apt.dirs
@@ -1 +1,2 @@
etc/kernel/postinst.d
+usr/share/bug/apt
diff --git a/debian/changelog b/debian/changelog
index 257219b4a..0043bfc88 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,24 @@
+apt (1.3~rc4) unstable; urgency=medium
+
+ [ Julian Andres Klode ]
+ * Fix segfault and out-of-bounds read in Binary fields
+ * TagFile: Fix off-by-one errors in comment stripping
+ * Base256ToNum: Fix uninitialized value
+ * test-apt-cdrom: Fix for gnupg 2.1.15
+ * CMake: test/libapt: Use a prebuilt GTest library if available
+ * CMake: apt-pkg: Use correct ICONV_INCLUDE_DIRS variable
+ * acquire: Use priority queues and a 3 stage pipeline design
+ => faster updates with better progress reporting
+ * debian: Move bugscript to old location for overlayfs xdev issue
+ * debian: Pass -O to make to get readable build logs
+
+ [ David Kalnischkies ]
+ * try not to call memcpy with length 0 in hash calculations
+ * re-add apt breaks/replaces apt-utils (<< 1.3~exp2~) (Closes: #836220)
+ * support long keyid and fingerprint in gpgv's GOODSIG
+
+ -- Julian Andres Klode <jak@debian.org> Fri, 02 Sep 2016 20:26:36 +0200
+
apt (1.3~rc3ubuntu2) yakkety; urgency=medium
* test-apt-cdrom: Fix for gnupg 2.1.15
diff --git a/debian/control b/debian/control
index 582259e20..772339511 100644
--- a/debian/control
+++ b/debian/control
@@ -36,6 +36,8 @@ Depends: adduser,
${apt:keyring},
${misc:Depends},
${shlibs:Depends}
+Replaces: apt-utils (<< 1.3~exp2~)
+Breaks: apt-utils (<< 1.3~exp2~)
Recommends: gnupg | gnupg2 | gnupg1
Suggests: apt-doc,
aptitude | synaptic | wajig,
diff --git a/debian/rules b/debian/rules
index 24608a6b8..2f1ea45fc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -34,3 +34,6 @@ override_dh_auto_configure-arch: flags=-DWITH_DOC=OFF
override_dh_auto_configure-indep: flags=-DWITH_DOC=ON
override_dh_auto_configure-arch override_dh_auto_configure-indep:
dh_auto_configure -- $(flags)
+
+override_dh_auto_build:
+ dh_auto_build -- -O