summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <mvo@ubuntu.com>2014-05-05 17:13:24 +0200
committerMichael Vogt <mvo@ubuntu.com>2014-05-05 17:13:24 +0200
commitb4278cc96fa0184b4f522e2bcfe82bd8eba93595 (patch)
tree59969ad6463918810ca264854615e8b2cfdf0bad /debian
parentf3594b9de99745c84563bac3ef59a159e30d4cd8 (diff)
parent3fa4e98f62e469f4292d2811b4e15f4afb678fbd (diff)
Merge branch 'debian/sid' into ubuntu/master
Conflicts: configure.ac debian/apt.dirs debian/changelog
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.dirs1
-rw-r--r--debian/changelog50
-rwxr-xr-xdebian/rules2
3 files changed, 50 insertions, 3 deletions
diff --git a/debian/apt.dirs b/debian/apt.dirs
index 1e8b057eb..ecbcdbc0a 100644
--- a/debian/apt.dirs
+++ b/debian/apt.dirs
@@ -16,4 +16,3 @@ var/lib/apt/periodic
var/log/apt
usr/share/apt
usr/share/bug/apt
-usr/share/bash-completion/completions/
diff --git a/debian/changelog b/debian/changelog
index 73dc53244..da1fb02e6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,53 @@
+apt (1.0.3ubuntu1) UNRELEASED; urgency=low
+
+ * Merged from debian/sid, remaining changes:
+ - patch for apt cross-building, see http://bugs.debian.org/666772
+ - ubuntu changelog download handling
+ - apt-key net-update/apt-xapian-index
+ - git-buildpackage config adjustments
+ - ubuntu keyring
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Mon, 05 May 2014 16:56:22 +0200
+
+apt (1.0.3) unstable; urgency=medium
+
+ [ Michael Vogt ]
+ * reduce delta to ubuntu
+ * provide support for vendor specific config files
+ * debian/apt-doc.docs: remove README.MultiArch
+ * Fix missing ScreenWidth check in apt.cc
+ * Only do openpty() if both stdin/stdout are terminals (Closes: 746434)
+
+ [ David Kalnischkies ]
+ * add a README for vendor information
+ * remove outdated README.MultiArch
+ * build http request in a stringstream
+ * enforce LFS for partial files in https range requests
+ * handle pkgnames shorter than modifiers (Closes: 744940)
+ * allow vendors to install configuration files
+
+ [ John Ogness ]
+ * properly undo CD-ROM mount in all error cases
+
+ [ Mahyuddin Ramli ]
+ * add vendor information for BlankOn (Closes: 743595)
+
+ [ Adam Conrad ]
+ * fix FileFd::Size bitswap on big-endian architectures (Closes: 745866)
+
+ [ Trần Ngọc Quân ]
+ * l10n: vi.po: Update one new string
+
+ -- Michael Vogt <mvo@debian.org> Mon, 05 May 2014 14:03:15 +0200
+
+apt (1.0.2ubuntu2) utopic; urgency=medium
+
+ * apt-pkg/contrib/fileutl.cc: When checking gzip filesizes, cast
+ size to uint32_t before setting it, so we don't end up playing
+ with the wrong half of a uint64_t on big-endian architectures.
+
+ -- Adam Conrad <adconrad@ubuntu.com> Fri, 25 Apr 2014 19:34:04 -0600
+
apt (1.0.2ubuntu1) utopic; urgency=low
* merged with debian/sid, remaining changes:
diff --git a/debian/rules b/debian/rules
index c013c3a55..d89a36cde 100755
--- a/debian/rules
+++ b/debian/rules
@@ -191,8 +191,6 @@ apt: build-binary build-manpages debian/apt.install
cp share/ubuntu-archive.gpg debian/$@/usr/share/$@
cp debian/apt.auto-removal.sh debian/$@/etc/kernel/postinst.d/apt-auto-removal
chmod 755 debian/$@/etc/kernel/postinst.d/apt-auto-removal
- # install bash completion
- cp share/bash-completions/* debian/$@/usr/share/bash-completion/completions/
# install vendor specific apt confs
find -L vendor/current -name 'apt.conf-*' | while read conf; do cp "$${conf}" "debian/$@/etc/apt/apt.conf.d/$${conf#*-}"; done