summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDavid Kalnischkies <kalnischkies@gmail.com>2010-05-06 16:15:53 +0200
committerDavid Kalnischkies <kalnischkies@gmail.com>2010-05-06 16:15:53 +0200
commitd1aa91622b3e0f7653889cab205e4c5c622162f4 (patch)
tree2daa36375c215c86df9b98c435d7899402748287 /debian
parent2d847a5919828ab26dd3f3c5993497b95df9051b (diff)
parentd7087c493bf2fc7a0eaf6fa308c496c81e6dc98f (diff)
merge with debian-experimental-ma
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog83
-rw-r--r--debian/control5
-rwxr-xr-xdebian/rules3
3 files changed, 59 insertions, 32 deletions
diff --git a/debian/changelog b/debian/changelog
index 144d307fa..43f76a18e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,20 +1,31 @@
-apt (0.7.26~exp4) UNRELEASED; urgency=low
+apt (0.7.26~exp5) UNRELEASED; urgency=low
- [ Michael Vogt ]
- * [ Abi break ] apt-pkg/acquire-item.{cc,h}:
- - add "IsIndexFile" to constructor of pkgAcqFile so that it sends
- the right cache control headers
- * apt-pkg/depcache.cc:
- - fix incorrect std::cout usage for debug output
- * test/libapt/getlanguages_test.cc:
- - Add test for Esperanto that has nocounty associated with them
- (LP: #560956)
+ [ David Kalnischkies ]
+ * cmdline/apt-get.cc:
+ - rerun dpkg-source in source if --fix-broken is given (Closes: #576752)
+ - don't suggest held packages as they are installed (Closes: #578135)
+ * cmdline/apt-cache.cc:
+ - use GroupCount for package names in stats and add a package struct line
+ * methods/rred.cc:
+ - use the patchfile modification time instead of the one from the
+ "old" file - thanks to Philipp Weis for noticing! (Closes: #571541)
+ * debian/rules:
+ - remove targets refering to CVS or arch as they are useless
+
+ [ Jari Aalto ]
+ * debian/rules:
+ - spell out some less known options to reduce manpage consulation-rate
+ - Use POSIX command substitution: $(<command sequence>)
+ - Remove EOL whitespace (Closes: #577804)
+
+ -- David Kalnischkies <kalnischkies@gmail.com> Thu, 06 May 2010 16:10:39 +0200
+
+apt (0.7.26~exp4) experimental; urgency=low
[ David Kalnischkies ]
* apt-pkg/depcache.cc:
- rewrite the pseudo package reinstaller to be more intelligent
in his package choices
- - return in SingleArch a package also for "any"
* apt-pkg/packagemanager.cc:
- don't try to "unpack" pseudo packages twice
* apt-pkg/contrib/fileutl.cc:
@@ -33,8 +44,6 @@ apt (0.7.26~exp4) UNRELEASED; urgency=low
- regex for package names executed on Grp- not PkgIterator
- show non-candidates as fallback for virtual packages (Closes: #578385)
- set also "all" to this version for pseudo packages in TryToChangeVer
- - rerun dpkg-source in source if --fix-broken is given (Closes: #576752)
- - don't suggest held packages as they are installed (Closes: #578135)
* apt-pkg/deb/dpkgpm.cc:
- remove Chroot-Directory from files passed to install commands.
Thanks to Kel Modderman for report & patch! (Closes: #577226)
@@ -43,7 +52,6 @@ apt (0.7.26~exp4) UNRELEASED; urgency=low
* cmdline/apt-cache.cc:
- align Installed and Candidate Version in policy so they can be compared
easier, thanks Ralf Gesellensetter for the pointer! (Closes: #578657)
- - use GroupCount for package names in stats and add a package struct line
* doc/apt.ent:
- Add a note about APT_CONFIG in the -c description (Closes: #578267)
* doc/po/de.po:
@@ -60,11 +68,6 @@ apt (0.7.26~exp4) UNRELEASED; urgency=low
* apt-pkg/pkgcache.h:
- enhance the Groups ABI by providing a ID as the other structs does
- check also the size of the Group struct then checking for the others
- * methods/rred.cc:
- - use the patchfile modification time instead of the one from the
- "old" file - thanks to Philipp Weis for noticing! (Closes: #571541)
- * debian/rules:
- - remove targets refering to CVS or arch as they are useless
[ Jari Aalto ]
* cmdline/apt-get.cc:
@@ -73,12 +76,39 @@ apt (0.7.26~exp4) UNRELEASED; urgency=low
* dselect/install:
- modernize if-statements not to use 'x' (Closes: #577117)
- replace backticks with POSIX $() (Closes: #577116)
+
+ [ Michael Vogt ]
+ * [ Abi break ] apt-pkg/acquire-item.{cc,h}:
+ - add "IsIndexFile" to constructor of pkgAcqFile so that it sends
+ the right cache control headers
+ * cmdline/apt-get.cc:
+ - fix crash when pkg.VersionList() is empty
+ * apt-pkg/depcache.cc:
+ - fix incorrect std::cout usage for debug output
+ * test/libapt/getlanguages_test.cc:
+ - Add test for Esperanto that has nocounty associated with them
+ (LP: #560956)
+ * apt-pkg/deb/debrecords.cc:
+ - fix max tag buffer size (LP: #545336, closes: #578959)
* debian/rules:
- - spell out some less known options to reduce manpage consulation-rate
- - Use POSIX command substitution: $(<command sequence>)
- - Remove EOL whitespace (Closes: #577804)
+ - install html doxygen in libapt-pkg-doc
+ * debian/control:
+ - build-depend on doxygen
+
+ [ Julian Andres Klode ]
+ * apt-pkg/contrib/weakptr.h:
+ - add a class WeakPointable which allows one to register weak pointers to
+ an object which will be set to NULL when the object is deallocated.
+ * [ABI break] apt-pkg/acquire{-worker,-item,}.h:
+ - subclass pkgAcquire::{Worker,Item,ItemDesc} from WeakPointable.
+ * apt-pkg/pkgcache.cc:
+ - Merge fix from David to correct handling in single-arch environments.
+ * cmdline/apt-cache.cc:
+ - Add a showauto command to apt-cache.
+ * cmdline/apt-get.cc:
+ - Add apt-get markauto and unmarkauto commands.
- -- David Kalnischkies <kalnischkies@gmail.com> Sat, 03 Apr 2010 14:58:39 +0200
+ -- Michael Vogt <mvo@debian.org> Thu, 06 May 2010 09:32:54 +0200
apt (0.7.26~exp3) experimental; urgency=low
@@ -1584,13 +1614,6 @@ apt (0.7.6) unstable; urgency=low
-- Otavio Salvador <otavio@debian.org> Wed, 01 Aug 2007 19:49:51 -0300
-apt (0.7.6) unstable; urgency=low
-
- * Applied patch from Aurelien Jarno <aurel32@debian.org> to fix wrong
- directory downloading on non-linux architectures (closes: #435597)
-
- -- Otavio Salvador <otavio@debian.org> Wed, 01 Aug 2007 19:49:51 -0300
-
apt (0.7.5) unstable; urgency=low
[ Otavio Salvador ]
diff --git a/debian/control b/debian/control
index f0178d571..4f41c130b 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,7 @@ Uploaders: Michael Vogt <mvo@debian.org>, Otavio Salvador <otavio@debian.org>,
Christian Perrier <bubulle@debian.org>, Daniel Burrows <dburrows@debian.org>,
Luca Bruno <lethalman88@gmail.com>, Julian Andres Klode <jak@debian.org>
Standards-Version: 3.8.4
-Build-Depends: debhelper (>= 5.0), libdb-dev, gettext (>= 0.12), libcurl4-gnutls-dev | libcurl3-gnutls-dev (>= 7.15.5), debiandoc-sgml, xsltproc, docbook-xsl, po4a (>= 0.34-2), autotools-dev, autoconf, automake
+Build-Depends: debhelper (>= 5.0), libdb-dev, gettext (>= 0.12), libcurl4-gnutls-dev | libcurl3-gnutls-dev (>= 7.15.5), debiandoc-sgml, xsltproc, docbook-xsl, po4a (>= 0.34-2), autotools-dev, autoconf, automake, doxygen
Build-Conflicts: autoconf2.13, automake1.4
Package: apt
@@ -51,6 +51,9 @@ Section: doc
Description: Documentation for APT development
This package contains documentation for development of the APT
Debian package manipulation program and its libraries.
+ .
+ This includes the source code documentation generated by doxygen
+ in html format.
Package: apt-utils
Architecture: any
diff --git a/debian/rules b/debian/rules
index bb2cc34c3..cb4622779 100755
--- a/debian/rules
+++ b/debian/rules
@@ -145,7 +145,8 @@ libapt-pkg-doc: build-doc debian/shlibs.local
$(BLD)/docs/files* \
$(BLD)/docs/method* \
doc/libapt-pkg2_to_3.txt \
- doc/style.txt
+ doc/style.txt \
+ $(BLD)/doc/doxygen/html
dh_installexamples -p$@
dh_installchangelogs -p$@