summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2016-08-18 10:02:35 +0200
committerJulian Andres Klode <jak@debian.org>2016-08-18 10:02:35 +0200
commitd1fd09b982f6108dc32ec75330b0535236c48311 (patch)
treec0dce6cf7501c1e0d5e3bad34e9b63c0d6dcd354 /debian
parentb5fcba3682581b2a48921cc830dbf3deae6b0ff3 (diff)
parent43670e2ef8b689d9efba633d11d2a5fc6f9968a0 (diff)
Merge tag '1.3_rc2' into ubuntu
apt Debian release 1.3~rc2
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.install2
-rw-r--r--debian/changelog29
-rw-r--r--debian/control6
-rwxr-xr-xdebian/rules2
-rw-r--r--debian/tests/control3
5 files changed, 37 insertions, 5 deletions
diff --git a/debian/apt.install b/debian/apt.install
index 82b9ec6f4..a8a56c925 100644
--- a/debian/apt.install
+++ b/debian/apt.install
@@ -29,7 +29,7 @@ usr/share/man/*/*/apt-mark.*
usr/share/man/*/*/apt-secure.*
usr/share/man/*/*/sources.list.*
usr/share/man/*/*/apt_preferences.*
-completions/bash/* /usr/share/bash-completion/completions/
+usr/share/bash-completion/completions/
debian/*.service /lib/systemd/system/
debian/*.timer /lib/systemd/system/
usr/lib/apt/apt-helper
diff --git a/debian/changelog b/debian/changelog
index a69ebff45..8d2289a21 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,32 @@
+apt (1.3~rc2) unstable; urgency=medium
+
+ [ Julian Andres Klode ]
+ * debian/NEWS: Get rid of 1.3~pre3+cmake1 entry.
+ Thanks to Axel Beckert for reporting
+ * CMake: Use COPYONLY instead of @ONLY
+ * fileutl: empty file support: Avoid fstat() on -1 fd and check result
+ * Change anonscm.d.o links to /git/apt/apt.git and https
+
+ [ David Kalnischkies ]
+ * don't perform int<float in progress bar drawing
+ * ensure a good clock() value for usage and tests
+ * drop incorrect const attribute from DirectoryExists (LP: 1473674)
+ * http(s): allow empty values for header fields (Closes: 834048)
+ * don't sent Range requests if we know its not accepted
+ * don't try pipelining if server closes connections (Closes: #832113)
+ * log with the failed item description, not with next try
+ * retry without same redirection mirror on 404 errors
+ * support getting only-uncompressed files via by-hash
+ * support compression and by-hash for .diff/Index files (Closes: #824926)
+ * default to Dir=/ in dpkg/status file finding magic
+ * add the gpg-classic variant to the gpgv/gnupg or-group
+ * allow spaces in fingerprints for 'apt-key del'
+ * add --with-source option and Packages/Sources support
+ * don't count each Type as an individual deb822-sources stanza
+ * methods: read config in most to least specific order (Closes: 834642)
+
+ -- Julian Andres Klode <jak@debian.org> Wed, 17 Aug 2016 23:31:07 +0200
+
apt (1.3~rc1ubuntu2) yakkety; urgency=medium
* Don't build with -O3. See LP: #1473674.
diff --git a/debian/control b/debian/control
index 4d4dd97e5..535d3693d 100644
--- a/debian/control
+++ b/debian/control
@@ -15,15 +15,15 @@ Build-Depends: dpkg-dev (>= 1.17.14), debhelper (>= 9.20141010), libdb-dev,
Build-Depends-Indep: doxygen, w3m, graphviz
Build-Conflicts: autoconf2.13, automake1.4
Vcs-Git: https://anonscm.debian.org/git/apt/apt.git
-Vcs-Browser: https://anonscm.debian.org/cgit/apt/apt.git
+Vcs-Browser: https://anonscm.debian.org/git/apt/apt.git
Testsuite: autopkgtest
Package: apt
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, ${apt:keyring}, gpgv | gpgv2, adduser
+Depends: ${shlibs:Depends}, ${misc:Depends}, ${apt:keyring}, gpgv | gpgv2 | gpgv1, adduser
Replaces: manpages-pl (<< 20060617-3~), manpages-it (<< 2.80-4~), sun-java6-jdk (>> 0), sun-java5-jdk (>> 0), openjdk-6-jdk (<< 6b24-1.11-0ubuntu1~), bash-completion (<< 1:2.1-4.2+fakesync1), apt-utils (<< 1.3~exp2~)
Breaks: manpages-pl (<< 20060617-3~), manpages-it (<< 2.80-4~), sun-java6-jdk (>> 0), sun-java5-jdk (>> 0), openjdk-6-jdk (<< 6b24-1.11-0ubuntu1~), apt-utils (<< 1.3~exp2~)
-Recommends: gnupg | gnupg2
+Recommends: gnupg | gnupg2 | gnupg1
Suggests: aptitude | synaptic | wajig, dpkg-dev (>= 1.17.2), apt-doc, python-apt, powermgmt-base
Description: commandline package manager
This package provides commandline tools for searching and
diff --git a/debian/rules b/debian/rules
index b36db7cb8..f662944f5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,6 +13,8 @@ export DEB_CFLAGS_MAINT_APPEND := -O2
# do not fail as we are just experimenting with symbol files for now
export DPKG_GENSYMBOLS_CHECK_LEVEL=0
+export CTEST_OUTPUT_ON_FAILURE=1
+
%:
dh $@ --with systemd --parallel --buildsystem=cmake
diff --git a/debian/tests/control b/debian/tests/control
index 406679d37..b7555dc2e 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -1,4 +1,5 @@
Tests: run-tests
Restrictions: allow-stderr
-Depends: @, @builddeps@, fakeroot, wget, stunnel4, lsof, db-util, gnupg, gnupg2,
+Depends: @, @builddeps@, fakeroot, wget, stunnel4, lsof, db-util,
+ gnupg, gnupg1, gpgv, gpgv1,
libfile-fcntllock-perl, python3-apt