summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <michael.vogt@ubuntu.com>2013-01-09 08:25:14 +0100
committerMichael Vogt <michael.vogt@ubuntu.com>2013-01-09 08:25:14 +0100
commitd52f514fd380cdeef7ff68a54f81b82932d113cf (patch)
tree3c0d1ef2843fda42c8695fee49e53cfa5081a880 /debian
parent34c2a164242d06b206abfde18e28990908aa9c58 (diff)
parent50816ce74432f24135aefc590361bbb8ccfc71f1 (diff)
merge train fixes
Diffstat (limited to 'debian')
-rw-r--r--debian/apt.cron.daily2
-rw-r--r--debian/changelog9
-rwxr-xr-xdebian/rules2
3 files changed, 11 insertions, 2 deletions
diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 5c00f22db..27f08dd4a 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -289,7 +289,7 @@ random_sleep()
fi
if [ -z "$RANDOM" ] ; then
# A fix for shells that do not have this bash feature.
- RANDOM=$(dd if=/dev/urandom count=1 2> /dev/null | cksum | cut -c"1-5")
+ RANDOM=$(dd if=/dev/urandom bs=2 count=1 2> /dev/null | cksum | cut -d' ' -f1 | cut -c"1-5")
fi
TIME=$(($RANDOM % $RandomSleep))
debug_echo "sleeping for $TIME seconds"
diff --git a/debian/changelog b/debian/changelog
index 46213d779..840d9ebd9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,15 @@ apt (0.9.7.8) UNRELEASED; urgency=low
Closes: #697577
* fix missing translated apt.8 manpages, thanks to Helge Kreutzmann
for the report. Closes: #696923
+ * apt-pkg/contrib/progress.cc:
+ - Make "..." translatable to fix inconsistencies in the output
+ of e.g. apt-get update. While this adds new translatable strings,
+ not having translations for them will not break anything.
+ Thanks to Guillem Jover. Closes: #696225
+ * debian/apt.cron.daily:
+ - when reading from /dev/urandom, use less entropy and fix a rare
+ bug when the random number chksum is less than 1000.
+ Closes: #695285
-- Christian Perrier <bubulle@debian.org> Mon, 24 Dec 2012 07:01:20 +0100
diff --git a/debian/rules b/debian/rules
index 83e23881c..5051dab4f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -172,7 +172,7 @@ apt-doc: build-debiandoc
# Build architecture-dependent files here.
binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
-apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
+apt_MANPAGES = apt apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
apt: build build-manpages
dh_testdir -p$@
dh_testroot -p$@