summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Vogt <mvo@debian.org>2014-02-27 16:46:05 +0100
committerMichael Vogt <mvo@debian.org>2014-02-27 22:34:57 +0100
commited9665aedf77b3b8345bd4ed33de7885738e29f0 (patch)
tree8fa63b4e39e614852fcf9a2047ed2e2aa8b3926d /debian
parentfc104da6a583736223b2f941e43a05ea26b63a7d (diff)
initial version of apt-helper
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules3
-rw-r--r--debian/tests/run-tests1
2 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 1b3782ab6..eec016607 100755
--- a/debian/rules
+++ b/debian/rules
@@ -207,6 +207,9 @@ apt: build-binary build-manpages debian/apt.install
#mv debian/$@/usr/bin/apt-report-mirror-failure \
# debian/$@/usr/lib/apt/apt-report-mirror-failure \
+ # move the apt-helper in place
+ mv debian/$@/usr/bin/apt-helper debian/$@/usr/lib/apt/apt-helper
+
dh_bugfiles -p$@
dh_lintian -p$@
dh_installexamples -p$@ $(BLD)/docs/examples/*
diff --git a/debian/tests/run-tests b/debian/tests/run-tests
index 6dc4eaa93..e03db9b0c 100644
--- a/debian/tests/run-tests
+++ b/debian/tests/run-tests
@@ -14,5 +14,6 @@ make -C test/interactive-helper/
# run against the installed apt
APT_INTEGRATION_TESTS_WEBSERVER_BIN_DIR=$(pwd)/build/bin \
APT_INTEGRATION_TESTS_METHODS_DIR=/usr/lib/apt/methods \
+APT_INTEGRATION_TESTS_LIBEXEC_DIR=/usr/lib/apt/ \
APT_INTEGRATION_TESTS_BUILD_DIR=/usr/bin \
./test/integration/run-tests