summaryrefslogtreecommitdiff
path: root/methods/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2017-06-28 10:55:57 +0200
committerJulian Andres Klode <jak@debian.org>2017-06-28 15:52:38 +0200
commit2851ec6cf037d552118b885be0dd7796d74730c6 (patch)
tree31fddfa989f328b28806149435857c753dfcfd5f /methods/CMakeLists.txt
parent5666084ecfe140aaa3f89388de557c2f875b4244 (diff)
methods: Add HTTPS support to http method, using GnuTLS
The http method will eventually replace the curl-based https method, but for now, this is an opt-in experiment that can be enabled by setting Dir::Bin::Methods::https to "http". Known issues: - We do not support HTTPS proxies yet - We do not support proxying HTTPS connections yet (CONNECT) - IssuerCert and SslForceVersion are unsupported Gbp-Dch: Full
Diffstat (limited to 'methods/CMakeLists.txt')
-rw-r--r--methods/CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/methods/CMakeLists.txt b/methods/CMakeLists.txt
index a74c2ce07..64807e310 100644
--- a/methods/CMakeLists.txt
+++ b/methods/CMakeLists.txt
@@ -11,7 +11,8 @@ add_executable(ftp ftp.cc rfc2553emu.cc connect.cc)
add_executable(rred rred.cc)
add_executable(rsh rsh.cc)
-# Add target-specific header directories
+target_compile_definitions(http PRIVATE ${GNUTLS_DEFINITIONS})
+target_include_directories(http PRIVATE ${GNUTLS_INCLUDE_DIR})
target_include_directories(https PRIVATE ${CURL_INCLUDE_DIRS})
# Link the executables against the libraries
@@ -20,10 +21,10 @@ target_link_libraries(copy apt-pkg)
target_link_libraries(store apt-pkg)
target_link_libraries(gpgv apt-pkg)
target_link_libraries(cdrom apt-pkg)
-target_link_libraries(http apt-pkg)
-target_link_libraries(mirror apt-pkg ${RESOLV_LIBRARIES})
+target_link_libraries(http apt-pkg ${GNUTLS_LIBRARIES})
+target_link_libraries(mirror apt-pkg ${RESOLV_LIBRARIES} ${GNUTLS_LIBRARIES})
target_link_libraries(https apt-pkg ${CURL_LIBRARIES})
-target_link_libraries(ftp apt-pkg)
+target_link_libraries(ftp apt-pkg ${GNUTLS_LIBRARIES})
target_link_libraries(rred apt-pkg)
target_link_libraries(rsh apt-pkg)