summaryrefslogtreecommitdiff
path: root/methods/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Kalnischkies <david@kalnischkies.de>2017-11-18 12:38:21 +0100
committerDavid Kalnischkies <david@kalnischkies.de>2018-01-03 19:42:45 +0100
commit4df5483994d510290677abab5720445f71babe65 (patch)
treea649a9bfbbc07a6446b5a1baca50033fc7093f5b /methods/CMakeLists.txt
parenta839efb126af066dc2e58400fb5e25911cb2a9f1 (diff)
non-local mirrorlists shouldn't redirect to local
A mirror list we get from an non-local source like http shouldn't be able to include e.g. file sources and even with other online sources we need to be careful: They also shouldn't include prefixed methods like 'tor+http'. So apply magic based on how the method is called: mirror+file will be allowed to redirect to any source while tor+mirror+file allows all, but sends them to their tor+ variant.
Diffstat (limited to 'methods/CMakeLists.txt')
-rw-r--r--methods/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/methods/CMakeLists.txt b/methods/CMakeLists.txt
index cf5ab799d..c4a32b4f5 100644
--- a/methods/CMakeLists.txt
+++ b/methods/CMakeLists.txt
@@ -26,7 +26,7 @@ target_link_libraries(ftp ${GNUTLS_LIBRARIES})
install(TARGETS file copy store gpgv cdrom http ftp rred rsh mirror
RUNTIME DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/apt/methods)
-add_slaves(${CMAKE_INSTALL_LIBEXECDIR}/apt/methods mirror mirror+http mirror+https mirror+file)
+add_slaves(${CMAKE_INSTALL_LIBEXECDIR}/apt/methods mirror mirror+ftp mirror+http mirror+https mirror+file mirror+copy)
add_slaves(${CMAKE_INSTALL_LIBEXECDIR}/apt/methods rsh ssh)