summaryrefslogtreecommitdiff
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2017-06-28 00:12:11 +0200
committerJulian Andres Klode <jak@debian.org>2017-06-28 15:52:38 +0200
commit0fe2161020d6e331639ed11872a947dd20035890 (patch)
tree876f3836313ee70230b21c781d700c77a482d8ac /po/CMakeLists.txt
parent2851ec6cf037d552118b885be0dd7796d74730c6 (diff)
Allow building without curl
This makes testing easier and prepares us for the transition.
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
index 258c9b050..2630a2f89 100644
--- a/po/CMakeLists.txt
+++ b/po/CMakeLists.txt
@@ -10,12 +10,18 @@ apt_add_translation_domain(
EXCLUDE_LANGUAGES ${languages_excluded}
)
+if (HAVE_CURL)
+ set(curl_methods https)
+else()
+ set(curl_methods)
+endif()
+
apt_add_translation_domain(
DOMAIN apt
TARGETS apt apt-cache apt-get apt-config apt-cdrom apt-helper apt-mark
apt-private
# Methods
- file copy store gpgv cdrom http https ftp rred rsh mirror
+ file copy store gpgv cdrom http ${curl_methods} ftp rred rsh mirror
SCRIPTS ../dselect/install ../dselect/update
EXCLUDE_LANGUAGES ${languages_excluded}
)