summaryrefslogtreecommitdiff
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2017-06-28 19:15:41 +0200
committerJulian Andres Klode <jak@debian.org>2017-06-28 19:15:41 +0200
commit11c3624ce3575076ca52350f66d4bd2e63db5d73 (patch)
tree5bdd7020c8d42e9bb502fb0bbb4c3dc85450d446 /po/CMakeLists.txt
parent930e2df52dc637039c1845905d79ce525faeb8ca (diff)
parent147ac0fc90d972a11f5e91521ba3d385015b5945 (diff)
Merge branch 'feature/http-https'
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
index 258c9b050..2630a2f89 100644
--- a/po/CMakeLists.txt
+++ b/po/CMakeLists.txt
@@ -10,12 +10,18 @@ apt_add_translation_domain(
EXCLUDE_LANGUAGES ${languages_excluded}
)
+if (HAVE_CURL)
+ set(curl_methods https)
+else()
+ set(curl_methods)
+endif()
+
apt_add_translation_domain(
DOMAIN apt
TARGETS apt apt-cache apt-get apt-config apt-cdrom apt-helper apt-mark
apt-private
# Methods
- file copy store gpgv cdrom http https ftp rred rsh mirror
+ file copy store gpgv cdrom http ${curl_methods} ftp rred rsh mirror
SCRIPTS ../dselect/install ../dselect/update
EXCLUDE_LANGUAGES ${languages_excluded}
)