summaryrefslogtreecommitdiff
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Andres Klode <jak@debian.org>2016-08-07 16:01:18 +0200
committerJulian Andres Klode <jak@debian.org>2016-08-10 16:11:05 +0200
commit9a5537fcc6d3ea98909360636a45bd3cf3aba1d1 (patch)
treef0e408f948ace96798964e7bb7eaf53873f6f484 /po/CMakeLists.txt
parent6ff8727a0641b299ac32bc897d3ac1246b02061e (diff)
CMake: Translations: Build apt-all.pot and update .po files
Merge all the per-domain templates into one template file using msgcomm, stripping any line numbers in the input files, and sorting the output per file. This should create reasonably stable .pot and .po files that do not change just because files move around. It should also be resilient against some line changes, as long as one translated line is not moved before/after another translated line. Gbp-Dch: ignore
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
index c7dfcb0fb..4fdac3959 100644
--- a/po/CMakeLists.txt
+++ b/po/CMakeLists.txt
@@ -26,3 +26,13 @@ apt_add_translation_domain(
DOMAIN libapt-inst${APT_INST_MAJOR}
TARGETS apt-inst
)
+
+apt_add_update_po(
+ TEMPLATE
+ apt-all
+ DOMAINS
+ libapt-pkg${APT_PKG_MAJOR}
+ libapt-inst${APT_INST_MAJOR}
+ apt
+ apt-utils
+)