summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index df446bc56..13ce4540d 100644
--- a/configure.in
+++ b/configure.in
@@ -74,6 +74,13 @@ AC_CHECK_HEADER(db.h,
LIBS="$saveLIBS"
+AC_CHECK_LIB(curl, curl_easy_init,
+ [AC_CHECK_HEADER(curl/curl.h,
+ curl_ok=yes,
+ curl_ok=no)],
+ AC_MSG_ERROR([failed: I need CURL due https support]),
+)
+
AC_SUBST(BDBLIB)
dnl Converts the ARCH to be something singular for this general CPU family