summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 22 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index b2880c99c..ecc0cecce 100644
--- a/configure.in
+++ b/configure.in
@@ -17,11 +17,12 @@ AC_INIT(configure.in)
AC_CONFIG_AUX_DIR(buildlib)
AC_CONFIG_HEADER(include/config.h:buildlib/config.h.in include/apti18n.h:buildlib/apti18n.h.in)
-dnl -- SET THIS TO THE RELEASE VERSION --
-AC_DEFINE_UNQUOTED(VERSION,"0.8.2")
PACKAGE="apt"
+PACKAGE_VERSION="0.9.0"
AC_DEFINE_UNQUOTED(PACKAGE,"$PACKAGE")
+AC_DEFINE_UNQUOTED(PACKAGE_VERSION,"$PACKAGE_VERSION")
AC_SUBST(PACKAGE)
+AC_SUBST(PACKAGE_VERSION)
dnl Check the archs, we want the target type.
AC_CANONICAL_SYSTEM
@@ -31,6 +32,10 @@ AC_CHECK_TOOL_PREFIX
AC_PROG_CC
AC_ISC_POSIX
+dnl check for large file support and enable it if possible
+dnl do this early as other stuff might depend on it
+AC_SYS_LARGEFILE
+
dnl Check for other programs
AC_PROG_CXX
AC_PROG_CPP
@@ -83,9 +88,21 @@ AC_CHECK_LIB(curl, curl_easy_init,
AC_SUBST(BDBLIB)
+HAVE_ZLIB=no
AC_CHECK_LIB(z, gzopen,
- [AC_CHECK_HEADER(zlib.h, [], AC_MSG_ERROR([failed: zlib.h not found]))],
+ [AC_CHECK_HEADER(zlib.h, [HAVE_ZLIB=yes], AC_MSG_ERROR([failed: zlib.h not found]))],
AC_MSG_ERROR([failed: Need libz]))
+AC_SUBST(HAVE_ZLIB)
+if test "x$HAVE_ZLIB" = "xyes"; then
+ AC_DEFINE(HAVE_ZLIB)
+fi
+
+HAVE_BZ2=no
+AC_CHECK_LIB(bz2, BZ2_bzopen,[AC_CHECK_HEADER(bzlib.h, [HAVE_BZ2=yes], [])], [])
+AC_SUBST(HAVE_BZ2)
+if test "x$HAVE_BZ2" = "xyes"; then
+ AC_DEFINE(HAVE_BZ2)
+fi
dnl Converts the ARCH to be something singular for this general CPU family
dnl This is often the dpkg architecture string.
@@ -151,7 +168,7 @@ if test "$cross_compiling" = "yes" -a "x$archline" = "x"; then
AC_MSG_ERROR(When cross compiling, architecture must be present in sizetable)
fi
AC_C_BIGENDIAN
-
+
dnl We do not need this if we have inttypes!
HAVE_C9X=yes
if test x"$apt_cv_c9x_ints" = x"no"; then
@@ -214,4 +231,4 @@ fi
AC_SUBST(USE_NLS)
AC_PATH_PROG(BASH, bash)
-AC_OUTPUT(environment.mak:buildlib/environment.mak.in makefile:buildlib/makefile.in doc/Doxyfile,make -s dirs)
+AC_OUTPUT(environment.mak:buildlib/environment.mak.in makefile:buildlib/makefile.in doc/Doxyfile:doc/Doxyfile.in,make -s dirs)