summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index f599b44aa..ff8ab5923 100644
--- a/configure.in
+++ b/configure.in
@@ -70,7 +70,7 @@ AC_SUBST(PTHREADLIB)
dnl Converts the ARCH to be the same as dpkg
AC_MSG_CHECKING(system architecture)
-archset="`awk '$1 == "'$host_cpu'" { print $2 }' $srcdir/buildlib/archtable`"
+archset="`awk '$1 == \"$host_cpu\" { print $2 }' $srcdir/buildlib/archtable`"
if test "x$archset" = "x"; then
AC_MSG_ERROR(failed: use --host=)
fi
@@ -85,7 +85,7 @@ AC_CACHE_CHECK([for C9x integer types],c9x_ints,[
dnl Check the sizes etc. of the architecture
changequote(,)
-if archline="`sed -ne 's/^'$archset':[ ]\+\(.*\)/\1/gp' $srcdir/buildlib/sizetable`"; then
+if archline="`grep '^$archset' | cut -f 2- -d ' '`";then
changequote([,])
set $archline
if test "$1" = "little"; then