summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index de2d698b6..f56a9a7c6 100644
--- a/configure.in
+++ b/configure.in
@@ -18,7 +18,7 @@ AC_CONFIG_AUX_DIR(buildlib)
AC_CONFIG_HEADER(include/config.h:buildlib/config.h.in include/apti18n.h:buildlib/apti18n.h.in)
dnl -- SET THIS TO THE RELEASE VERSION --
-AC_DEFINE_UNQUOTED(VERSION,"0.7.7")
+AC_DEFINE_UNQUOTED(VERSION,"0.7.9")
PACKAGE="apt"
AC_DEFINE_UNQUOTED(PACKAGE,"$PACKAGE")
AC_SUBST(PACKAGE)
@@ -74,6 +74,13 @@ AC_CHECK_HEADER(db.h,
LIBS="$saveLIBS"
+AC_CHECK_LIB(curl, curl_easy_init,
+ [AC_CHECK_HEADER(curl/curl.h,
+ curl_ok=yes,
+ curl_ok=no)],
+ AC_MSG_ERROR([failed: I need CURL due https support]),
+)
+
AC_SUBST(BDBLIB)
dnl Converts the ARCH to be something singular for this general CPU family