summaryrefslogtreecommitdiff
path: root/debian/changelog
diff options
context:
space:
mode:
Diffstat (limited to 'debian/changelog')
-rw-r--r--debian/changelog47
1 files changed, 47 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 5b3c1a470..c113a9597 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,45 @@
+apt (0.7.21) UNRELEASED; urgency=low
+
+ [ Osamu Aoki ]
+ * Updated cron script to support backups by hardlinks and
+ verbose levels. All features turned off by default.
+ * Added more error handlings. Closes: #438803, #462734, #454989,
+ * Refactored condition structure to make download and upgrade performed
+ if only previous steps succeeded. Closes: #341970
+ * Documented all cron script related configuration items in
+ configure-index.
+
+ [ Michael Vogt ]
+ * apt-pkg/indexcopy.cc:
+ - support having CDs with no Packages file (just a Packages.gz)
+ by not forcing a verification on non-existing files
+ (LP: #255545)
+ - remove the gettext from a string that consists entirely
+ of variables (LP: #56792)
+ * doc/makefile:
+ - add examples/apt-https-method-example.conf
+ * apt-pkg/cacheiterators.h:
+ - add missing checks for Owner == 0 in end()
+ * apt-pkg/deb/dpkgpm.cc:
+ - fix potential hang when in a backgroud process group
+ * apt-pkg/indexrecords.cc:
+ - fix some i18n issues
+ * apt-pkg/contrib/strutl.h:
+ - add new strprintf() function to make i18n strings easier
+ * methods/gpgv.cc:
+ - fix compiler warning
+ * cmdline/apt-get.cc:
+ - fix "apt-get source pkg=ver" if binary name != source name
+ and show a message (LP: #202219)
+ * apt-pkg/deb/debsystem.cc:
+ - make strings i18n able
+
+ [ Dereck Wonnacott ]
+ * apt-ftparchive might write corrupt Release files (LP: #46439)
+ * Apply --important option to apt-cache depends (LP: #16947)
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Fri, 12 Sep 2008 11:34:24 +0200
+
apt (0.7.20) unstable; urgency=low
[ Eugene V. Lyubimkin ]
@@ -14,6 +56,11 @@ apt (0.7.20) unstable; urgency=low
(Closes: #438559)
[ Michael Vogt ]
+ * apt-pkg/depcache.cc:
+ - when checking for new important deps, skip critical ones
+ (LP: #236360)
+ * document --install-recommends and --no-install-recommends
+ (thanks to Dereck Wonnacott, LP: #126180)
* make "apt-get build-dep" installed packages marked automatic
by default. This can be changed by setting the value of
APT::Get::Build-Dep-Automatic to false (thanks to Aaron