summaryrefslogtreecommitdiff
path: root/debian/changelog
diff options
context:
space:
mode:
Diffstat (limited to 'debian/changelog')
-rw-r--r--debian/changelog27
1 files changed, 21 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index a06abbbc0..f32f7a282 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,24 @@
apt (0.8.16~exp7) UNRELEASEDexperimental; urgency=low
+ [ David Kalnischkies ]
+ * do not pollute namespace in the headers with using (Closes: #500198)
+ * use forward declaration in headers if possible instead of includes
+ * remove old APT_COMPATIBILITY ifdef's
+ * apt-pkg/deb/dpkgpm.cc:
+ - use std::vector instead of fixed size arrays to store args and
+ multiarch-packagename strings
+ - load the dpkg base arguments only one time and reuse them later
+ * cmdline/apt-get.cc:
+ - follow Provides in the evaluation of saving candidates, too, for
+ statisfying garbage package dependencies (Closes: #640590)
+ * apt-pkg/algorithms.cc:
+ - if a package is garbage, don't try to save it with FixByInstall
+ * apt-pkg/deb/debsrcrecords.cc:
+ - remove the limit of 400 Binaries for a source package (Closes: #622110)
+ * apt-pkg/deb/deblistparser.cc:
+ - fix crash when the dynamic mmap needs to be grown in
+ LoadReleaseInfo (LP: #854090)
+
[ Michael Vogt ]
* apt-pkg/contrib/configuration.cc:
- fix double delete (LP: #848907)
@@ -8,17 +27,13 @@ apt (0.8.16~exp7) UNRELEASEDexperimental; urgency=low
- fix fetching language information by adding OptionalSubIndexTarget
* methods/https.cc:
- cleanup broken downloads properly
-
+
[ Colin Watson ]
* ftparchive/cachedb.cc:
- fix buffersize in bytes2hex
- [ David Kalnischkies ]
- * apt-pkg/deb/deblistparser.cc:
- - fix crash when the dynamic mmap needs to be grown in
- LoadReleaseInfo (LP: #854090)
- -- Michael Vogt <michael.vogt@ubuntu.com> Wed, 05 Oct 2011 18:14:11 +0200
+ -- David Kalnischkies <kalnischkies@gmail.com> Wed, 05 Oct 2011 18:40:57 +0200
apt (0.8.16~exp6) experimental; urgency=low