summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 1446a039e..30474c06b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -100,7 +100,12 @@ build/build-stamp: build/configure-stamp
# compat symlink for the locale split
mkdir -p build/usr/share
cd build/usr/share && ln -f -s ../../locale .
- # done here
+ # compile and run tests
+ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
+ $(MAKE) test
+else
+ @echo "Tests DISABLED"
+endif
touch $@
build/build-doc-stamp: build/configure-stamp