summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 6 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 4f6d72e06..e4ecfbdd7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -125,8 +125,8 @@ build/build-doc-stamp: build/configure-stamp
clean:
dh_testdir
# dh_testroot
- -$(MAKE) clean
- -$(MAKE) distclean
+ [ -f Makefile ] && $(MAKE) clean
+ [ -f Makefile ] && $(MAKE) distclean
rm -rf build
@@ -186,7 +186,7 @@ apt-doc: build-doc
# Build architecture-dependent files here.
binary-arch: apt libapt-pkg-dev apt-utils apt-transport-https
-apt: build debian/shlibs.local
+apt: build build-doc debian/shlibs.local
dh_testdir -p$@
dh_testroot -p$@
dh_clean -p$@ -k
@@ -219,6 +219,9 @@ apt: build debian/shlibs.local
cp debian/apt.conf.ubuntu debian/$@/etc/apt/apt.conf.d/01ubuntu
# head -n 500 ChangeLog > debian/ChangeLog
+ # copy lintian override
+ cp share/lintian-overrides debian/$@/usr/share/lintian/overrides/apt
+
# make rosetta happy and remove pot files in po/ (but leave stuff
# in po/domains/* untouched) and cp *.po into each domain dir
rm -f build/po/*.pot