summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 0101a303d..6761177f9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,11 +24,11 @@ ifneq (,$(shell which dpkg-buildflags))
# make does not export to $(shell) so we need to workaround
# (http://savannah.gnu.org/bugs/?10593)
dpkg_buildflags = DEB_BUILD_MAINT_OPTIONS=hardening=+all dpkg-buildflags
-
+
# workaround gcc-5 compile error
# (see https://bugs.launchpad.net/ubuntu/+source/gcc-5/+bug/1473674)
export CXXFLAGS = $(subst -O3,-O2,$(shell $(dpkg_buildflags) --get CXXFLAGS))
-
+
export LDFLAGS = $(shell $(dpkg_buildflags) --get LDFLAGS)
export CPPFLAGS = $(shell $(dpkg_buildflags) --get CPPFLAGS)
else