summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules111
1 files changed, 87 insertions, 24 deletions
diff --git a/debian/rules b/debian/rules
index d194ba1cf..13912e9f7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,8 +2,10 @@
# Made with the aid of dh_make, by Craig Small
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.23 2000/06/04 05:37:30 doogie Exp $
+# $Id: rules,v 1.24 2001/02/20 07:03:17 jgg Exp $
+# LD_LIBRARY_PATH=pwd/debian/tmp/usr/lib dh_shlibdeps -papt
+# dpkg: /home/jgg/work/apt2/debian/tmp/usr/lib/libapt-pkg.so.2.9 not found.
# For the deb builder, you can run 'debian/rules cvs-build', which does all
# steps nescessary to produce a proper source tarball with the CVS/ removed.
@@ -12,6 +14,12 @@
# create ../upload-<VER>, with all the files needed to be uploaded placed
# in it.
+# See below
+include build/environment.mak
+
+# Default rule
+build:
+
DEB_BUILD_PROG:=debuild -us -uc
APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
@@ -31,6 +39,7 @@ ifeq ($(words $(BLD)),0)
override BLD := ./build
endif
+# Rebuild configure.in to have the correct version from the change log
ifneq ($(APT_DEBVER),$(APT_CONFVER))
.PHONY: configure.in
configure.in:
@@ -39,27 +48,46 @@ else
configure.in:
endif
+# APT Programs in apt-utils
+APT_UTILS=ftparchive sortpkgs
+
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
# Find the libapt-pkg major version for use in other control files
-export LIBAPT_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
+export LIBAPTPKG_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
+export LIBAPTINST_MAJOR:=$(shell egrep '^MAJOR=' apt-inst/makefile |cut -d '=' -f 2)
debian/shlibs.local: apt-pkg/makefile
- rm -f $@
- echo "libapt-pkg $(LIBAPT_MAJOR) libapt-pkg$(LIBAPT_MAJOR)" >> $@
- echo "libapt-pkg $(LIBAPT_MAJOR) apt $(APT_DEBVER)" >> $@
+ # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
+ # one for the rest of the packages. This ensures that each package gets
+ # the right overrides..
+ rm -rf $@ $@.apt $@.apt-utils
+ echo "libapt-pkg $(LIBAPTPKG_MAJOR)" > $@.apt
+
+ echo "libapt-pkg $(LIBAPTPKG_MAJOR) libapt-pkg$(LIBAPTPKG_MAJOR)" > $@.apt-utils
+ echo "libapt-inst $(LIBAPTINST_MAJOR)" >> $@.apt-utils
-build: build-stamp
-build-stamp: configure
+ echo "libapt-pkg $(LIBAPTPKG_MAJOR) libapt-pkg$(LIBAPTPKG_MAJOR)" > $@
+ echo "libapt-inst $(LIBAPTINST_MAJOR) libapt-inst$(LIBAPTINST_MAJOR)" >> $@
+
+build: build/build-stamp
+
+# Note that this is unconditionally done first as part of loading environment.mak
+# The true is needed to force make to reload environment.mak after running
+# configure-stamp. Otherwise we can get stale or invalid, or missing config data.
+build/environment.mak: build/configure-stamp
+ @true
+
+configure: configure.in
+build/configure-stamp: configure
dh_testdir
-mkdir build
(cd build; ../configure)
-# cd build && CXXFLAGS="-g -Wall -D_POSIX_C_SOURCE=199309" ../configure --disable-nls --disable-static --prefix=/usr
-# cd build && make all-hdr
-# cd build && make -s
+ touch $@
+build/build-stamp: build/configure-stamp
# Add here commands to compile the package.
- $(MAKE)
+ $(MAKE) -s
touch $@
clean:
@@ -67,7 +95,8 @@ clean:
# dh_testroot
rm -f build-stamp debian/shlibs.local
rm -rf build
-
+ rm -f debian/shlibs.local.apt debian/shlibs.local.apt-utils
+
# Add here commands to clean up after the build process.
-$(MAKE) clean
-$(MAKE) distclean
@@ -84,7 +113,8 @@ libapt-pkg-doc: build debian/shlibs.local
# libapt-pkg-doc install
#
dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
- $(BLD)/docs/files* $(BLD)/docs/method*
+ $(BLD)/docs/files* $(BLD)/docs/method* \
+ doc/libapt-pkg2_to_3.txt doc/style.txt
-cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/doc/libapt-pkg-doc/.dhelp
-cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/share/doc/libapt-pkg-doc/.dhelp
@@ -102,14 +132,14 @@ libapt-pkg-doc: build debian/shlibs.local
dh_fixperms -p$@
# dh_suidregister -p$@
dh_installdeb -p$@
- dh_gencontrol -p$@ -u -Vlibapt-pkg:major=${LIBAPT_MAJOR}
+ dh_gencontrol -p$@ -u -Vlibapt-pkg:major=$(LIBAPTPKG_MAJOR)
dh_md5sums -p$@
dh_builddeb -p$@
# Build architecture-dependent files here.
-binary-arch: apt libapt-pkg-dev
+binary-arch: apt libapt-pkg-dev apt-utils
apt: build debian/shlibs.local
dh_testdir -p$@
dh_testroot -p$@
@@ -120,6 +150,9 @@ apt: build debian/shlibs.local
#
cp $(BLD)/bin/apt-* debian/tmp/usr/bin/
+ # Remove the bits that are in apt-utils
+ rm $(addprefix debian/tmp/usr/bin/apt-,$(APT_UTILS))
+
# install the shared libs
find $(BLD)/bin/ -type f -name "libapt-pkg.so.*" -exec cp -a "{}" debian/tmp/usr/lib/ \;
find $(BLD)/bin/ -type l -name "libapt-pkg.so.*" -exec cp -a "{}" debian/tmp/usr/lib/ \;
@@ -129,26 +162,27 @@ apt: build debian/shlibs.local
cp $(BLD)/scripts/dselect/* debian/tmp/usr/lib/dpkg/methods/apt/
# Copy the guides
- dh_installdocs -p$@ $(BLD)/docs/guide.text $(BLD)/docs/guide.html \
+ dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
$(BLD)/docs/offline.text $(BLD)/docs/offline.html
# One or the other..
-cp -a debian/dhelp debian/tmp/usr/doc/apt/.dhelp
- -cp -a debian/dhelp debian/tmp/usr/share/doc/apt/.dhelp
+ -cp -a debian/dhelp debian/tmp/usr/share/doc/apt/.dhelp
# head -n 500 ChangeLog > debian/ChangeLog
dh_installexamples -p$@ $(BLD)/docs/examples/*
- dh_installmanpages -p$@
+ dh_installmanpages -p$@ apt-ftparchive.1 apt-sortpkgs.1
dh_installchangelogs -p$@
dh_strip -p$@
dh_compress -p$@
dh_fixperms -p$@
dh_installdeb -p$@
- LD_LIBRARY_PATH=`pwd`/debian/tmp/usr/lib dh_shlibdeps -papt
- dh_gencontrol -p$@ -u -Vlibapt-pkg:major=${LIBAPT_MAJOR}
- dh_makeshlibs -m${LIBAPT_MAJOR} -Vlibapt-pkg${LIBAPT_MAJOR} -papt
+ dh_shlibdeps -papt -l`pwd`/debian/tmp/usr/lib -- -Ldebian/shlibs.local.apt
+# LD_LIBRARY_PATH=`pwd`/debian/tmp/usr/lib dh_shlibdeps -papt
+ dh_gencontrol -p$@ -u -Vlibapt-pkg:major=$(LIBAPTPKG_MAJOR)
+ dh_makeshlibs -m$(LIBAPTPKG_MAJOR) -V 'libapt-pkg$(LIBAPTPKG_MAJOR)' -papt
dh_md5sums -p$@
dh_builddeb -p$@
@@ -161,7 +195,8 @@ libapt-pkg-dev: build debian/shlibs.local
# libapt-pkg-dev install
#
cp -a $(BLD)/bin/libapt-pkg.so debian/libapt-pkg-dev/usr/lib/
- #ln -s libapt-pkg.so.${LIBAPT_MAJOR} debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
+ cp -a $(BLD)/bin/libapt-inst.so debian/libapt-pkg-dev/usr/lib/
+ #ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
dh_installdocs -p$@
@@ -176,11 +211,39 @@ libapt-pkg-dev: build debian/shlibs.local
dh_fixperms -p$@
# dh_suidregister -p$@
dh_installdeb -p$@
- dh_gencontrol -p$@ -u -Vlibapt-pkg:major=${LIBAPT_MAJOR}
+ dh_gencontrol -p$@ -u -Vlibapt-pkg:major=$(LIBAPTPKG_MAJOR)
+ dh_md5sums -p$@
+ dh_builddeb -p$@
+
+apt-utils: build debian/shlibs.local
+ dh_testdir -p$@
+ dh_testroot -p$@
+ dh_clean -p$@ -k
+ dh_installdirs -p$@
+
+ # install the shared libs
+ find $(BLD)/bin/ -type f -name "libapt-inst.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
+ find $(BLD)/bin/ -type l -name "libapt-inst.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
+
+ cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
+ dh_installdocs -p$@
+
+ # Install the man pages..
+ mkdir -p debian/$@/usr/share/man/man1
+ cp doc/apt-sortpkgs.1 doc/apt-ftparchive.1 debian/$@/usr/share/man/man1/
+
+ dh_installchangelogs -p$@
+ dh_strip -p$@
+ dh_compress -p$@
+ dh_fixperms -p$@
+ dh_installdeb -p$@
+ LD_LIBRARY_PATH=`pwd`/debian/tmp/usr/lib:`pwd`/debian/$@/usr/lib dh_shlibdeps -p$@ -- -Ldebian/shlibs.local.apt-utils
+ dh_gencontrol -p$@ -u -Vlibapt-inst:major=$(LIBAPTINST_MAJOR)
+ dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V 'libapt-inst$(LIBAPTINST_MAJOR)' -p$@
dh_md5sums -p$@
dh_builddeb -p$@
-source diff:
+source diff:
@echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
# Update from CVS